3

I'm using the packages newtxtext and newtxmath.

\documentclass[12pt,a4paper]{report}
\usepackage{amssymb}
\usepackage{newtxtext}
\usepackage[noamssymbols]{newtxmath}

\begin{document}
$ \vdash \nvdash \vDash\nvDash$
\end{document}

This is what I got.

enter image description here

I want the $\vdash$ symbol look the same as the others. What should I do?

1
  • 3
    Remove the noamssymbols option
    – egreg
    Mar 11, 2014 at 17:24

1 Answer 1

4

The symbol \vdash is not defined by amssymb but it is contained in fontmath.ltx, so adding the option noamssymbols when loading newtxmath has no effect on it.

You can add the following lines in your preamble

\DeclareSymbolFont{mysymbols}{OMS}{cmsy}{m}{n}
\DeclareMathSymbol{\vdash}{\mathrel}{mysymbols}{96}

to achieve what you want:

enter image description here

MWE:

\documentclass[12pt,a4paper]{report}
\usepackage{amssymb}
\usepackage{newtxtext}
\usepackage[noamssymbols]{newtxmath}

\DeclareSymbolFont{mysymbols}{OMS}{cmsy}{m}{n}
\DeclareMathSymbol{\vdash}{\mathrel}{mysymbols}{96}

\begin{document}
$ \vdash \nvdash \vDash\nvDash$
\end{document} 

Otherwise, if you want all symbols in NewTX style, simply remove the option noamssymbols when loading newtxmath, as suggested by egreg.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .