1

When the write into texwork the following :

 \begin{algorithm}[H]
\SetAlgoLined
\KwData{this text}
\KwResult{how to write algorithm with \LaTeX2e }
initialization\;
\While{not at end of this document}{
read current\;
\eIf{understand}{
go to next section\;
current section becomes this one\;
}{
go back to the beginning of current section\;
}
}
\caption{How to write algorithms}
\end{algorithm}

error occurs:

This is LuaTeX, Version beta-0.76.0-2013062820 (rev 4627) I can't find the format file `miktex-luatex.fmt'! What is the reason? Please .... Do I find help??

closed as unclear what you're asking by Torbjørn T., Joseph Wright Aug 2 '14 at 21:18

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Welcome to TeX.SX! Can you please show some effort on your part in terms of attempting a solution? – karlkoeller Mar 13 '14 at 5:35
  • it not run ,When I write in my texworks shows a error.I can't find the format file `miktex-luatex.fmt'! – user47878 Mar 13 '14 at 5:49
  • The message indicates you are trying to run luatex on what is presumably a LaTeX (or LuaLaTeX?) file: have you tried lualatex from the TeXworks dropdown? That may solve the issues, but it does sound as if something is up with your LuaTeX installation. I'd try using the MiKTeX settings and choosing 'Rebuild formats' – Joseph Wright Mar 15 '14 at 14:37

Browse other questions tagged or ask your own question.