0

is there a way to make TeXstudio's shortcuts behave as one would expect on OS X? In particular, Command+Left usually moves the cursor to the beginning of the line, but in TeXstudio it takes me left a word. Similarly, Alt-Left usually moves the cursor a word to the left, but in TeXstudio it moves the cursor to the previous edit location.

  • Does this solve the problem? The other solution in a general cases is to overwrite the shortcuts from OS X settings (you can even assign shortcuts for those commands that don't have one by default). P.S. I also agree, texstudio has some really annoying shortcuts on OS X. – Pouya Mar 14 '14 at 14:58
  • You have it as an answer! – Pouya Mar 14 '14 at 15:42
  • Note: From the next version on (2.7.2) TeXstudio will provide more native shortcuts on OSX by default. – Tim Hoffmann Mar 23 '14 at 16:33
2

Modifying TeXstudio shortcuts are done from Configur->Shortcuts menu. Here you can find information in details:

enter image description here

If there is a shortcut (not only for this case, but in general) that you can't modify or a command has no shortcut assigned to, you can use OS X settings to solve the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.