5

I am using the following:

\documentclass[a4paper, 11pt]{article}
\usepackage[english,swedish]{babel}
\usepackage{graphicx}
\usepackage[T1]{fontenc}
\usepackage{xcolor,colortbl}
\usepackage[backend=bibtex,style=mla]{biblatex}

\nocite{*}

...


\begin{document}

text... \footcite{source}

\printbibliography[heading=none]


\end{document}

Why is there's an extra "print" after each source?

enter image description here

  • 1
    electronic, media or print – percusse Mar 14 '14 at 19:23
  • try and set showmedium=false in the options. – moewe Mar 14 '14 at 19:25
  • Note that you somewhat garbled Mr. Davis's name; it should be author = {Davis, III, Roy B. and Sylvia Õunpuu and Dennis Tyburski and James R. Gage}, and not author = {Roy B. Davis III and Sylvia Õunpuu and Dennis Tyburski and James R. Gage}, in the .bib file. (See How should I type author names in a bib file?) – moewe Mar 14 '14 at 19:46
9

The MLA style guide requires the medium of the publication to be shown (see, for example MLA Citation Style | Cornell University Library).

biblatex-mla tries to satisfy this requirement by printing the medium of publication at the end of every bibliography entry (via the macro publimedium). If the howpublished field contains any information, that information is printed. If howpublished is not given, the default option guessmedium is active, biblatex-mla will guess the medium of publication.

To stop biblatex-mla from printing this information, just use the option showmedium=false, so your call to biblatex becomes

\usepackage[backend=bibtex,style=mla,showmedium=false]{biblatex}

Your example reveals another problem though, "print" is printed in bold, to warn you that [the] Bibliography string 'print' [is] undefined (see log file).

biblatex-mla does not provide a Swedish language file, so some bibstrings are missing, to get this particular one back, try

\DefineBibliographyStrings{swedish}{%
  print = {whatever \enquote{print} means in Swedish},
}

Now, "print" is replaced by "whatever 'print' means in Swedish".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.