2

I am using the add-on import package of Donald Arseneau to typeset my thesis while allowing each thesis chapter files to be placed in a subfolder. Using this package lets me do it when I typeset my document with pdflatex but not with latex. It does not look for the files in the nested folders and complains that they are not found. Is there a solution to this problem? I prefer latex command for typesetting as it handles the .eps files better. I work in a linux environment. Below is a minimal compilable code that used. puthesis is a style file for Purdue University thesis.

\documentclass[me,dissertation]{puthesis}
\usepackage{graphicx}
\usepackage{import}
\begin{document}
\subimport{introduction/}{c.tex}
\subimport{summary/}{c.tex}
\end{document}
  • Welcome to TeX.SX! Please help us to help you and add a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}. – Mike Renfro Mar 15 '14 at 14:43
  • Thank you for the edits and the clarification. I was a little confused with that edit before. – Srinivas Mar 15 '14 at 15:41
  • @Srinivas OK, I'll tidy up the comments shortly – Joseph Wright Mar 15 '14 at 15:44
  • I tried your MWE and it worked with both latex and pdflatex, i.e. it includes the content of the files in the subdirectory. Are you using the newest puthesis class file? – user31729 Mar 15 '14 at 17:25
  • @Christian I tried the latest puthesis class file. I still have the problem. Here, is the error. TexLive 2012 (./t.tex LaTeX2e <2011/06/27> (./puthesis.cls Document Class: puthesis 2012/11/30 (/package/texlive/2012/amd64-RedHatEL/texmf-dist/tex/latex/base/ifthen.sty) ! LaTeX Error: File `introduction' not found. See the LaTeX manual or LaTeX Companion for explanation. Type H <return> for immediate help. ... l.4 \includegraphics{introduction} ? – Srinivas Mar 15 '14 at 19:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.