5

When I export the following org file to latex using C-c C-e d, the resulting tex file does not match my expectations in regards to the way the sections are being created. The exported subsections and subsubsections end up in itemize environments instead of \subsection{}'s. I tried to add #+OPTIONS: H:3, but the H-option does not affect the created tex file in any way. What can I do in order to get org to export the file as I intend?

.org:

#+TITLE: export
#+OPTIONS: H:3

* section 1
** subsection 1
** subsection 2
*** subsubsection 1
* Section 2

results in .tex

% Created 2014-03-16 Sun 17:46
\documentclass{article}

\title{export}
\date{16 March 2014}

\begin{document}

\setcounter{tocdepth}{3}
\tableofcontents
\vspace*{1cm}

\section{Section 1}
\label{sec-1}

\begin{itemize}

\item subsection 1\\
\label{sec-1.1}

\item subsection 2\\
\label{sec-1.2}

\begin{itemize}

\item subsubsection 1\\
\label{sec-1.2.1}

\end{itemize} % ends low level
\end{itemize} % ends low level

\section{Section 2}
\label{sec-2}

\end{document}
  • Did you make sure to apply the heading variable? C-c C-c the H:3 line. (You may also want to update—it would seem you are running Org 7 where the current version is Org 8, which introduces an entirely new exporter.) – Sean Allred Mar 16 '14 at 17:13
  • @SeanAllred I was not only running Org 7, I was running Org 6, which shipped with my emacs debian bundle. It explains all the weird behavior and the discrepancy to the official documentation I experienced. Thanks!! – kstudent Mar 17 '14 at 21:19
6
#+OPTIONS: H:3

* section
** subsection
*** subsubsection

Works for me under Org-mode version 8.2.5h (8.2.5h-30-gdd810b-elpa @ /…/org-20140303/). Make sure you apply the option on the first line with C-c C-c.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.