5

I am want to wrap text around image using pull quote from Two-column text with circular insert, but I wasn't able even to compile example file correctly. Is there anybody that has pull quotes working?

Image here: Esperanto_star.png (direct link; licence: public domain, cf. https://commons.wikimedia.org/wiki/File:Esperanto_star.png)

Minimal example:

\documentclass{article}
\usepackage{lipsum}
\usepackage[latin]{babel}
\usepackage{graphicx}

\usepackage{pullquote}

\begin{document}

\begin{pullquote}
{image={Esperanto_star},imageopts={scale=0.1},shape=rectangular}
  \lipsum[1-4]
\end{pullquote}

\begin{pullquote}
{image={Esperanto_star},imageopts={scale=0.1},shape=image}
  \lipsum[1-4]
\end{pullquote}

\end{document}

Example output:

Screenshot

  • 1
    Welcome to TeX.SX! Please help us to help you and add a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}. – Adam Liter Mar 16 '14 at 21:11
  • 5
    Welcome to TeX.SX. Can you post what you have? – Sean Allred Mar 16 '14 at 21:12
  • 1
    You nee to have imagemagick installed for this to work. Do you have it?. It works for me on miktex. – user11232 Mar 16 '14 at 22:54
3

You did not tell us anything about your configuration, so let me write here first two points also written in documentation of pullquote:

  • ImageMagick must be installed. In Windows it must be in system path before Windows folders (because in Windows a convert.exe with a fully other functionality exists). When you use the installer, this is done automatically, but for the portable version you have to make sure this on your own.

  • You must compile with the option -shell-escape (for MiKTeX the original command is -enable-write18, but the former alias works, as well).

But there is a third point not explicitly mentioned:

When you give the option shape=image, then the image filename is handled over to ImageMagick’s convert, hence you must give the file extension! Otherwise convert will complain about this, but its error message is unfortunately not copied into the log file.

\documentclass{article}
\usepackage{lipsum}
\usepackage[latin]{babel}
\usepackage{graphicx}
\usepackage{pullquote}
\begin{document}

\begin{pullquote}
{image={Esperanto_star.png},imageopts={scale=0.1},shape=image}
  \lipsum[1-4]
\end{pullquote}

\end{document}

screenshot of example output

The white space between the lower star beams is no error, but can by design not be avoided.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.