I'm having the following block layout on one frame

\subsection{Typen}
\begin{frame}
 Zwei Arten von Typen
 \begin{block}{Wertetypen mit \texttt{rt::ValueType}}
   {
   \setbeamertemplate{blocks}[rounded] % disable shadow
   \textit{Simple} oder \textit{Array}
   \begin{columns}
    \column[t]{.45\textwidth}
    \begin{block}{Bei \textit{Simple}}
     Der genaue Typ
    \end{block}
    \column[t]{.45\textwidth}
    \begin{block}{Bei \textit{Array}}
     Anzahl an Elementen
    \end{block}
   \end{columns}
   \setbeamertemplate{blocks}[default] % enable again
   }
 \end{block}
\end{frame}

But it creates an ugly vertical space before the column environment. If I comment out the 4 column-environment specific commands, the vertical space is gone, which makes me think it's the column-environment's fault.

Is there a way to remove that vertical initial space?

If you're after a local adjustment (i.e., only a few slides), can't you just add a \vskip-5em (or whatever space you want to remove) just after your \begin{frame}?

enter image description here

Otherwise, you can simply use \begin{frame}[t] (where t means top) to have your frame top-aligned. It can also be passed as a class option to align every frame.

enter image description here

  • I'm trying to put a two-column thing between two bullet points, so changing alignment won't help. I'll use the workaround, but this seems like a bug (at least, I'm seeing a lot of vertical space before the columns environment—about twice as much as appears after it, which doesn't seem like it'd be intentional). – Luke Maurer Dec 13 '15 at 12:15

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.