3

I have a MikTeX/WinEdt installation and I'd been using the "PDFTeXify" button to create PDF's that automatically open in Adobe Reader.

Somewhere along the line I opened GSView and accidentally told it to associate PDF's with GSView, and now whenever I "PDFTeXify" it tries to open the PDF in GSView but fails for some reason. I uninstalled and reinstalled both GSView and WinEdt, and made sure that Windows recognizes PDFs to be opened with Adobe Reader (right click a PDF file in Windows Explorer -> properties -> Open with...). When I reinstalled GSView I made sure to tell it NOT to associate PDF's with GSView. However, somehow the change seems to have stuck and PDFTexify still insists on opening in GSView and not Adobe Reader.

Any ideas on how to fix this? I'm assuming/hoping there's an option somewhere that sets the default program/reader to open PDF's when you compile but for the life of me I can't find it.

  • BTW: Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. – karlkoeller Mar 18 '14 at 11:14
3

In Adobe Reader, go to "Edit" -> "Preferences" -> "General" -> "Select Default PDF Handler", and choose the right one to recover the right file association.

Note that this happens because WinEdt launches by default the program associated with .pdf files.

Anyway, from within WinEdt, you can go to "Options" -> "Execution Modes" -> "PDF Viewer" and choose the reader of your choice even if it is not the one associated with .pdf files.

enter image description here

Just press the "Alternative Viewer" button corresponding to Adobe Reader.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.