4

I'm using Lyx and I want the pdf output to print Contents, new chapters and bib on a odd page. How can I do this?

What information do you require from lyx?
Class is Report.


Document > Configuration > Document class > Class options > write twoside,openright > Check that source code (view menu) start with \documentclass[english,twoside,openright]{report} – Fran

We are almost there!
Now My layout is

  1. Title Page
  2. Abstract // I'd want this on page 2.
  3. Blank (pg2)
  4. Contents (pg3)
  5. Blank (pg4)
  6. Chapter 1 (pg5)

What I really want is

  1. Title Page
  2. Blank <<<< EXTRA BLANK Page
  3. Abstract (p2)
  4. Blank (pg3)
  5. Contents (pg4)
  6. Blank (pg5)
  7. Chapter 1 (pg6)

What info do you need?


Okay I've found a solution.

I inserted Latex code (⌘L) \cleardoublepage{} before Abstract now it is beautiful!

  • 1
    Try adding twoside,openright to the document class options. – Torbjørn T. Mar 18 '14 at 18:44
  • 3
    Duplicate of tex.stackexchange.com/questions/6227/… I suppose? – Torbjørn T. Mar 18 '14 at 18:46
  • @TorbjørnT. This question is how to pipe that answer in the GUI Lyx. I'm new to Latex and currently I'd like to stay within my GUI. – Another Compiler Error Mar 18 '14 at 19:31
  • 3
    Document > Configuration > Document class > Class options > write twoside,openright > Check that source code (view menu) start with \documentclass[english,twoside,openright]{report} – Fran Mar 18 '14 at 19:41
  • "\documentclass[twoside,british,twoside,openright]{report}" – Another Compiler Error Mar 18 '14 at 19:44
4

Answer from Fran:

Document > Configuration > Document class > Class options > write twoside,openright > Check that source code (view menu) start with \documentclass[english,twoside,openright]{report} – Fran

In my case I also had to inserted Latex code (⌘L) \cleardoublepage{} before my abstract.


Amendment: I changed Abstract to an unnumbered chapter and removed \cleardoublepage{} because the previous action caused unusual page numbering before abstract page.

0

as in this link you don't need to change class settings, just go to

Document->Settings->Page Layout->Two-sided document

(the "openright" option is not needed, it is default).

you need after that to use: clear double page seperator between the chapters

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.