4

I sometimes use auctex + ess for Sweave/knitr documents.

Every time I switch from auctex to ess and vice versa, there is a pause/jolt while the auctex lines re-wrap themselves.

Previously, I also had outline/folding modes turned on which made it nearly unusable, but after turning those off I think I only have auctex's line wrapping feature keeping me from making a smooth transition between the two environments (in the same file/buffer).

How can I turn off this line-wrapping feature and keep it turned off? I assume it is associated with some hook; turning it off manually will not work because it will immediately re-initiate itself once I switch back from the ess to auctex environment.

4

The R chunks are in ESS mode, the LaTeX is in AucTeX. Whatever your settings are for each mode, they will apply in the appropriate part of the buffer. It seems to me that the mode hooks for each mode get run each time you switch contexts as well, so just setting the variables once won't do - you have to modify your hooks.

Which means the answer to your problem is to set appropriate values in your LaTeX-mode-hook. Sounds like maybe you're using visual-line-mode or toggle-truncate-lines?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.