6

I m trying to compile file using TeXworks. I use fithesis class because its pre-set class by my university for creating documents.

\documentclass[12pt,oneside,final]{fithesis}  
\usepackage[latin2] {inputenc}
\usepackage[T1] {fontenc}
\usepackage{csquot}
\usepackage{mflogo}


\thesistitle{Utoky pomocou fragmentacie IPv6} 
\thesissubtitle{Bakalarska praca}  
\thesisstudent{Michal Gasparovic}    
\thesisfaculty{fi}  
\thesisyear{jar 2014}  
\thesisadvisor{doc. RNDr. Eva Hladka, Ph.D.} 
\thesislang{sk}                 



\begin{document}  
\FrontMatter  
\ThesisTitlePage  

\begin{ThesisDeclaration}  
\DeclarationText  
\AdvisorName  
\end{ThesisDeclaration}  

\begin{ThesisThanks}  
Dakujem ti Brona.
\end{ThesisThanks}

\end{document}

Every time try to compile and error like this occur.

Trying to make PK font fi-logo at 514 DPI... Running miktex-makemf.exe... miktex-makemf: The fi-logo source file could not be found.

Running ttf2pk.exe... miktex-makepk: PK font fi-logo could not be created.

!pdfTeX error: pdflatex.EXE (file fi-logo): Font fi-logo at 514 not found ==> Fatal error occurred, no output PDF file produced! texify: pdflatex failed for some reason (see log file).

I have been trying to update FNDB for many times. My updmap.cfg contains Map mdbch.map line and i even tried to run initexmf --mkmaps as an admin but no difference.

7
  • 2
    Did you install the fi-logo.mf (it should go in a texmf tree in fonts/source)? Mar 19, 2014 at 17:22
  • Welcome to TeX.SX! You don't have to sign with your name since it automatically appears in the lower right corner of your post.
    – Adam Liter
    Mar 19, 2014 at 17:32
  • I dont have any fi-logo.mf file. only fi-logo.tfm placed texmf\fonts\tfm\ or fi-logo.514pk placed texmf\fonts\pk\.
    – Michal
    Mar 19, 2014 at 18:20
  • 1
    Then find the mf. It exists. I saw it while looking for your class. Mar 19, 2014 at 21:13
  • Mr. Ulrike Fischer you are one smart man. Thank you very much. Now it is compiled without any error and even .pdf file was generated. Many thanks again. As you told, i just downloaded fi-logo.mf and put it to the right directory and here we go, it works. <3
    – Michal
    Mar 19, 2014 at 21:44

2 Answers 2

5

Find fi-logo.mf (https://github.com/liskin/fithesis), copy it to fonts/source and update the FNDB.

2

Copy fi-logo.mf to C:\Program Files (x86)\MiKTeX 2.9\fonts\source\

Open Settings in C:\ProgramData\Microsoft\Windows\Start Menu\Programs\MiKTeX 2.9\Maintenance (Admin)

General tab -> Refresh FNDB

Logo should now compile properly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.