I've just installed the Basic version of MikTex 2.9 When i compile a file using pdflatex , it attempts to download the package "miktex-zzdb1-2.9.tar.lzma" .

It takes about 2-3 mins . Then it proceeds . ( After failing to download ).

I know that Basic version will add packages when needed . But each time i compile , it attemps to download the same package and fails. I'm getting impatient . ( In Linux , same file compiles in 1 sec )

Do i need to configure anything ? My Internet connection is very active

The commandline : [NOTE THIS WILL VARY PER USER]

downloading http: //mirror-cybernet.lums.edu.pk/pub/ctan/systems/win32/miktex/tm/packages/miktex-zzdb1-2.9.tar.lzma... pdflatex: A timeout was reached while receiving data from the server.

  • 4
    Run the MikTeX package updater manually in the package manager and see if it helps. Alternatively download the package manually (maybe from a different mirror) and place it in the correct MikTeX folder (don't know where myself). Also try to change your config to use a different mirror server. Apr 26, 2011 at 15:24
  • 1
    thats it, i changed the mirror server ...... thank you Martin.... Apr 26, 2011 at 18:10
  • 1
    I had the same problem. Set the mirror, problem solved. Oct 12, 2013 at 6:58

1 Answer 1


[Edited 2019 to show latest number of files (3) needed]

miktex-zzdbl1-2.9.tar.lzma is one of the currently three "database" packages needed by the package management of the miktex console. It contains the actual list of packages. If miktex can't download miktex-zzdbl1, miktex-zzdbl2 and miktex-zzdbl3 the package installation of the console and the on-the-fly installation can't work.

The failure can be temporary (that happens) but it also can be due to something in your system (firewall e.g.). Try in the miktex console a different repository. If this doesn't work: You can also download the three miktex-zzdbl-files and the packages you want to install from CTAN (tex-archive/systems/win32/miktex/tm/packages). Put them all in an empty folder and use this folder as local repository.

  • 2
    Thank you , The problem is with the Download Mirror : the mirror by default is set to a pakistan university . I've changed it to a china one , synchronized to it and now it works just fine . :) Silly thing..... Apr 26, 2011 at 18:09
  • 1
    @vettipayyan: If Ulrike's answer solved your problem, please accept it by clicking on the tickmark below the vote count. This shows that the answer solved your problem, and it assigns reputation points to the author of the answer (and to you!). If it wasn't this answer that eventually solved your problem, but something else, feel free to add your own answer about how you solved the problem and accept it.
    – doncherry
    Aug 21, 2011 at 12:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .