3

I am using svjour3 class from Springer, but for convenience I decided to use the Lyx templates. Everything went smoothly and I managed to get all the layouts and formatting as required.

However, I need to submit for publication in TeX format. When I export LaTex(plain) I get

\documentclass[12pt,english]{svjour3}

The expected output is

\documentclass[smallextended]{svjour3} 

Obviously, I can change that manually after export, but I am wondering if there is anything that I can do at the lyx configuration level so that it exports directly in the expected form?

3

There are some steps you can try, by modifying some things under Document --> Settings.

  • smallextended can be added under Document Class: Add smallextended to the Custom class options.

  • For the font size, look under Fonts. If Base size (see top right) is set to 12pt, change it to Default.

  • To remove english I think you need to go to Language and set Language package to None. Note that this will also remove babel from the packages, so you may not want to do so.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.