3

Skim Inverse Search doesn't work for me(Mac OS 10.9)

Everything works fine for Sublime Text 2 with LaTexTools, building etc. Skim pops out, fine. Test PDF looks good. I set up sync in Skim wish to have inverse search, unfortunately, doesn't work.

Please note: I have also set up Sublime Text 2, LaTexTools, Sumatra PDF viewer in windows before as well. Everything works perfect. I double-click on a line in pdf and sublime text navigates to my desired location. So does the inverse search in Skim works in the same gesture manner as Sumatra does? Or I need extra configuration in Mac OS?

Thanks in advance!

My version of app:(all application installed in default location and settings)

Mac os 10.9

Sublime Text 2.02

LaTexTools release 2014-3-12

Skim 1.4.8(82)

My Skim sync setup in the picture: Sync setup

  • Mine is fine(OSx 10.8.5). I am using latexmk and Cmd+shift+click work fine. I have this $pdflatex = 'xelatex -recorder --shell-escape -interaction=nonstopmode -halt-on-error -synctex=1' in my .latexmkrc . It might not be important. – Aung Mar 20 '14 at 18:21
  • 1
    Yes Cmd+shift+click works for me as well! Thanks! But here is another problem: how did you know that? I've searched for all documentation but I can not find such information. I think it will be nice for you to post the source (if exists) in case people like me who is interested to look into it. :D Thanks @Aung – Choushishi Mar 20 '14 at 20:48
  • okay I will post the answer. – Aung Mar 20 '14 at 20:53
4

Mine is fine(OSx 10.8.5). I am using latexmk and Cmd+shift+click work fine. I have this $pdflatex = 'xelatex -recorder --shell-escape -interaction=nonstopmode -halt-on-error -synctex=1' in my .latexmkrc . It might not be important.

For more information , please take a look here under the section Forward and Inverse Search.

  • To make it work I needed to go in the Skim preferences (cmd+,), in the Sync section, and select sublime text in the preset dropdown (instructions found here) – glS Aug 4 '18 at 19:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.