6

I'm working with scrreprt and I have loaded minitoc to have a short TOC after each chapter title. However when I give the \chapter command I get:

1 Chapter Title

I'd like to have:

Chapter 1

Chapter Title

like in the ordinary report document-class (which I'm not using because I like the page size and fonts of the scrreprt doc-class).

I've seen in this other thread the following piece of code but it requires the titlesec package. I'm not familiar with that package, besides I think I would get errors and warnings on top of what I'm already getting now.

\renewcommand*{\chapterformat}{%
\mbox{\scalebox{1.5}{\chapappifchapterprefix{\nobreakspace}}%
\scalebox{4}{\color{gray}\thechapter\autodot}\enskip}}

Can someone please help me get the result I'm wanting?

7

You don't need the titlesec package for that. It suffices to add the option chapterprefix=true when loading scrreprt.

Taking the code from egreg's answer at your previous question and adding the above option:

\documentclass[a4paper,10pt,chapterprefix=true]{scrreprt}

\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[italian]{babel}

\usepackage{amssymb, amsmath, amsfonts}
\usepackage{silence}

\WarningFilter{minitoc(hints)}{W0023}
\WarningFilter{minitoc(hints)}{W0028}
\WarningFilter{minitoc(hints)}{W0030}
\WarningFilter{minitoc(hints)}{W0024}

\WarningFilter{blindtext}{} % this takes care of the `blindtext` messages

\usepackage[math,bible]{blindtext}
%\usepackage{titlesec}
\usepackage{hyperref}
\hypersetup{pdfstartview=FitH}
\usepackage[italian]{cleveref}
\usepackage[italian]{minitoc}


%opening
\title{M.T.N.}
\author{Myself}
\date{}

\begin{document}

\maketitle
\thispagestyle{empty}
\clearpage
\mbox{}
\cleardoublepage

\dominitoc
\tableofcontents
\clearpage
\chapter{Topic One}

\minitoc
\clearpage
\section{First Topic}
\blindmathpaper

\section{Second Topic}
\blindtext

\subsection{Second Topic, first subsection}
\blindtext
\end{document} 

this is the result:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.