2

Sometimes, LaTeXput extra white lines around my \begin{quote}. I use just the basic memoir class without any customization. Any hint?

4
  • Would you like to prepare a short MWE that shows the effect? – moewe Mar 22 '14 at 16:36
  • 1
    What do you mean by extra lines ? Are you leaving empty lines before the quote? – Sigur Mar 22 '14 at 16:36
  • I mean extra vertical spaces, before and after the quote env. – gdm Mar 22 '14 at 17:05
  • 1
    Try adding \raggedbottom and \usepackage[bottom]{footmisc} to your preamble. If that doesn't work, please provide a full, but minimal example. (This is always advisable, and always polite and helpful to people who want to help you.) Note there is also \raggedbottomsection, which selectively sets \raggedbottom on pages where a new section is called. – jon Mar 22 '14 at 20:19
2

This can all depend on how you're setting things up.

If you stick with the basic parameter values for shaping and handling paragraphs then the spacing shouldn't be too bad:

\documentclass{memoir}
\usepackage{lipsum}
\begin{document}

\lipsum[1-2]
\begin{quote}
\lipsum[1]
\end{quote}
\lipsum[10]

\end{document}

enter image description here

But if you start tweaking with the general formatting such as in this next example:

\documentclass{memoir}
\usepackage{lipsum}
\setlength\parskip{2ex}
\setlength\parindent{0pt}
\begin{document}

\lipsum[1-2]
\begin{quote}
\lipsum[1]
\end{quote}
\lipsum[10]

\end{document}

Then the spacing gets a bit out of hand. Generally it is advised not to tamper with the value of \parskip.

Since you haven't provided a MWE (yet), I can only guess what's going on with your document. Nevertheless, there are a few things you can try.

First you can add some negative \vspace

\documentclass{memoir}
\usepackage{lipsum}
%\setlength\parskip{2ex}
%\setlength\parindent{0pt}
\begin{document}

\lipsum[1-2]
\vspace{-2ex}
\begin{quote}
\lipsum[1]
\end{quote}
\vspace{-2ex}
\lipsum[10]

\end{document}

Personally, I wouldn't be happy with this solution. The extra spacing around the quote environment helps set it apart from the rest of the text.

Another solution would be to define your own quote environment.

\documentclass{memoir}
\usepackage{lipsum}
\usepackage{enumitem}
\newenvironment{myquote}{%%
  \begin{itemize}[topsep=0pt]
  \item[]}{\end{itemize}}
\begin{document}

\lipsum[1-2]
\begin{myquote}
\lipsum[1]
\end{myquote}
\lipsum[10]

\end{document}

I've loaded the enumitem package to facilitate the spacing before and after the environment. And, certainly, you can set topsep to a value which gives you the aesthetic appearance you're looking for.

5
  • I can assure that I did not put any strange setting. The text body is full of footnotes, sometimes very long footnotes, and in some page I get many extra vertical space around the quote. Yes, vspace with negative value could be a solution... – gdm Mar 22 '14 at 17:04
  • Setting \parskip to some value (such as 2ex) isn't necessarily strange. For some documents it may be appropriate (though most on this site will disagree with me on that point). But changing \parskip can have unintended effect since its value is used in a variety of different structures. – A.Ellett Mar 22 '14 at 17:07
  • With \vsapce is quite impossibile to control the environment "padding"... – gdm Mar 22 '14 at 17:12
  • The \vspace solution is really only appropriate for tweaking things in a particular context, not a general approach. I would suggest defining your own quote environment if it's every occurrence of quote that's bothering you. – A.Ellett Mar 22 '14 at 17:15
  • 2
    My suspicion is @giuseppe's document, which has lots of footnotes, is (implicitly) typeset with \flushbottom (the default in a two-sided document), which will take advantage of environments like quote to fulfill the objective of having the textblock align at the bottom of the page (i.e., by 'stretching' the whitespace around the environment). The easiest solution, if I'm right, is to use \raggedbottom, which does not, however, end up looking too great. The other option is to make the footnotes be typeset flushbottom (e.g., with \usepackage[bottom]{footmisc}. – jon Mar 22 '14 at 20:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.