I'm hoping you can help out a clueless person. As a former mathematical physicist, I've used Tex or LaTeX to typeset just about everything under the sun. But when it comes to installing the thing, I feel like one of my Luddite relatives. I've visited the usual download sites many times over the past few years, and I can't even parse the language in the how-to.

I should say, I'm no longer in academia and so this stuff doesn't happen automatically anymore. And nobody outside of academia seems to have heard of TeX, so I can't get any person-to-person help. N.B., I'm using Windows these days.

Today I tried installing TeX for what must be the dozenth time. This time I downloaded ProTeXt and installed MiKTeX and TeXStudio.

I can typeset basic articles now (yay!). But I need to use graphics too. And my problem. When I try to use the command \usepackage{graphicx}, a TeXStudio dialog box pop up and says:

The required file tex\context\base\supp-pdf.mkii is missing. It is part of the package mptopdf. This package will be installed from…"

And I have the choice to install from the Web, a directory, or a CD.

So I choose to install from a directory. It asks what directory. I have no way of knowing what directory. So I scour C:\Program Files (x86)\MiKTeX, and discover that there is a file called mptopdf in location C:\Program Files (x86)\MiKTeX\tpm\packages. So I tell the dialog box to install from C:\Program Files (x86)\MiKTeX\tpm\packages.

Error message: "Not a local package repository."

Now, if a directory on my machine called packages, which contains a package called mptopdf, is not a 'local package repository,' then what is?

How can I get graphics to work in my installation?

Many thanks in advance. I'm not as dumb as I sound, but getting TeX post-academia has really stumped me.

  • 2
    You can only install from a directory if you first have filled such a directory with the packages. So choose "install from the web". – Ulrike Fischer Mar 22 '14 at 18:51
  • I tried that too. I chose an RIT mirror and it said, "The package will be installed from mirrors.rit.edu/CTAN/systems/win32/miktex/tm/packages." When I clicked "Install," the compile crashed with the error message "Error: Command crashed: pdflatex.exe -synctex=1 -interaction=nonstopmode "texstudio_qc1464".tex". – Jason Zimba Mar 22 '14 at 18:58
  • Try compiling from the command line or use texworks – Johannes_B Mar 22 '14 at 19:07
  • 1
    I can't speak regarding MiKTeX (abandoned it years ago), but TeX Live's installer defaults to a full installation. Installation instructions for the network installer or downloading an ISO file are available. – Mike Renfro Mar 22 '14 at 19:31
  • 1
    Does this help? tex.stackexchange.com/a/49343/17423 – Sean Allred Mar 22 '14 at 20:22

This is more of a comment, but it turned out to be too long.

If I'm imagining this correctly in my head, this is the sequence of events:

  1. You create a LaTeX-formatted file in and save it as foo.tex.
  2. You compile this file from within TeXstudio. This in turn calls pdflatex foo.tex.
  3. The pdftex engine provided by MiKTeX begins compiling the document and tries to load the graphicx package, as requested. Unfortunately, the package is not available, so a signal is sent to a sort of 'supervisor' process that MiKTeX uses for this situation.
  4. This process, manifesting itself as the dialog box you see, asks you if you would like to install the package over Web or from a local directory or local package repository.

    Now here is the kicker: you ask to install from a local package repository. What this really means (I think; I use TeX Live for Windows) is that you are going to show MiKTeX a local mirror of CTAN—the whole thing—and the directory you point to most certainly is not such. (This option would be useful for universities that actually do mirror CTAN on a network drive.)

Try it again, but install it from the Web this time.


Most of what I say stands as an explanation of why this is happening, but it looks like something more involved is going on from the error you provide:

Error: Command crashed:

pdflatex.exe -synctex=1 -interaction=nonstopmode "texstudio_qc1464.tex"

Compile from the command line (just run the above) and look for any strange error messages it outputs.

  • At work, where I use miktex, and load packages "on the fly" it quite often leads to such crashes. I'm sorry to say that I ignore them. The next compile usually works. It's shameful if course ... – Paul Stanley Mar 22 '14 at 22:10
  • @PaulStanley It's almost always preferable to just install the full distribution from the get-go. It's only 4GB—peanuts to today's storage. – Sean Allred Mar 22 '14 at 22:58
  • Absolutely. I have only inertia to blame. – Paul Stanley Mar 22 '14 at 23:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.