0

I am having an issue where my Table of Contents is so long that it goes onto a second page, but the page number then mysteriously jumps from the bottom center of the page to the upper right corner for JUST the second page of my ToC. I can't have just that one page's number there. It needs to be in the bottom center like the others.

The biggest issue that I have is that I have to use a unique document class type for my university's thesis requirements.

This is the section of the code from that class' document about the toc.

\def\tableofcontents{\@restonecolfalse\if@twocolumn\@restonecoltrue\onecolumn
 \fi\chapter*{\centerline{Table of Contents}
 \@mkboth{TABLE OF CONTENTS}{TABLE OF CONTENTS}}
% \contentsline{chapter}{\underline{Section}}{\underline{Page}}
 \@starttoc{toc}\if@restonecol\twocolumn\fi}

My actual thesis document code simply looks like this:

\pagenumbering{roman}%%% Begin Roman Numeral Numbering
\include{MyAbstract}%Abstract Page
\newpage
\tableofcontents % Table of Contents Page

Why is it suddenly doing this for only the second page of the ToC?

  • 1
    Welcome to TeX.SX! A tip: If you select code and click the button marked {} above the text field, it will be highlighted as you see from my edit. – Torbjørn T. Mar 22 '14 at 21:05
2

\pagestyle{plain} puts the page number centered in the footer. This is usually the page style for the first page of a chapter (or table of contents). The standard classes are using the page style plain as default. In your case there is probably another page style active (explicitly set or implicitly by the class). If the whole document should use page style plain put

\pagestyle{plain}

in the preamble and remove the other page style settings.

If only the table of contents should use page style plain (why?), then it can be done by a local change, e.g.:

\begingroup
  \cleardoublepage
  \pagestyle{plain}
  \tableofcontents
  \cleardoublepage
\endgroup
| improve this answer | |
  • but, if i remember correctly, \pagestyle{plain} doesn't have running heads, and that's implicitly required by the ise of \markboth in the (incomplete) example. – barbara beeton Mar 22 '14 at 23:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.