I have LuaLaTeX installed via MiKTeX 2.9 on Windows 7. I am trying to use fontspec to change my document to a different font than the default CMR fonts. Just invoking \usepackage{fontspec} is sufficient to cause the following cryptic error message:

! This is a LaTeX bug: check coding!
! Command name `\font_set:Nnn' already defined! Current meaning:
!   \protected\long macro:#1#2#3->\tex_font:D #1=#2 at #3\scan_stop:
! See the LaTeX3 documentation for further information.
! For immediate help type H .

l.602 \cs_new:Npn \font_set:Nnn
                                #1#2#3 {

Continuing by hitting return produces a second similar message, and then processing apparently finishes without further fuss or bother.

Is there something I can do about this?

Or do I just have to wait until MiKTeX picks up the next release of LuaLaTex?

closed as too localized by Andrew Swann, Mensch, Claudio Fiandrino, Thorsten, Martin Schröder Apr 5 '13 at 10:47

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

  • The underlying issue is the same as the one discussed in the question @Sharpie has pointed to. I'd therefore suggest it's a duplicate. – Joseph Wright Apr 27 '11 at 6:21
  • @Joseph, from the description and answers there, I'd say you are right. My only excuse is that I focused on LuaLaTex and ignored XeTex when searching for the problem before posting. – RBerteig Apr 27 '11 at 9:33

I ran into this bug a couple of weeks ago and I think the problem is not with LuaLaTeX, but with the fontspec package. Try upgrading that package.

See this question concerning the same error message, but produced by XeLaTeX:

xelatex compilation error

  • Letting MiKTeX's updater have its way with my install updated about 30 packages including fontspec. I can now compile without errors. – RBerteig Apr 27 '11 at 10:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.