1

Hi all I'm writing a book in LyX with the package minitoc. If i use \documentclass [10pt]{book} the minitoc is set in one page, but if I use 12pt the minitoc is set in 2 pages.

I want use the 12 pt but resize minitoc like was in 11pt!

Latex code:

%% LyX 2.0.7 created this file.  For more info, see http://www.lyx.org/.
%% Do not edit unless you really know what you are doing.
\RequirePackage{fix-cm}
\documentclass[10pt,oneside,italian]{book}
\usepackage[T1]{fontenc}
\usepackage[latin9]{inputenc}
\usepackage{listings}
\lstset{basicstyle={\ttfamily},
breaklines=true,
frame=TRBL,
frameround=ffff}
\usepackage{fancyhdr}
\pagestyle{fancy}
\setcounter{secnumdepth}{3}
\setcounter{tocdepth}{1}
\setlength{\parskip}{\smallskipamount}
\setlength{\parindent}{0pt}
\usepackage{float}
\usepackage{amsmath}
\usepackage{setspace}
\doublespacing

\makeatletter
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%% Textclass specific LaTeX commands.
\numberwithin{equation}{section}
\numberwithin{figure}{section}

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%% User specified LaTeX commands.
\usepackage{minitoc}
\renewcommand{\mtcfont }{\tiny}
\usepackage[Lenny]{fncychap}

\makeatother

\usepackage{babel}
\begin{document}
\dominitoc

\tableofcontents{}

\begin{singlespace}

\chapter{\noindent Cap1}
\end{singlespace}

\begin{singlespace}
\noindent \null 
\vfill
\begin{singlespace}
\minitoc
text text text text text text text text text text text text text text text text .
\end{singlespace}
\end{singlespace}


\section{Sec1}


\subsection{SubSec1}


\subsection{SubSec2}


\section{Sec2}


\subsection{SubSec1}


\subsection{SubSec2}


\section{Sec3}


\subsection{SubSec1}


\subsection{SubSec2}


\section{Sec4}


\subsection{SubSec1}


\section{Sec5}


\subsection{SubSec1}


\subsection{SubSec2}


\section{Sec6}


\subsection{SubSec1}


\subsection{SubSec2}


\section{Sec7}
\end{document}

with 10p the output is: toc in 1 page

with 12p the output is: toc in 2 pages

4
  • Hi, welcome to TeX.SX. I'm not sure exactly how this looks in LyX, but try adding an ERT (Insert --> TeX code) just before the minitoc, and write {\small in this, then insert a second ERT just after the minitoc, and write } here. Mar 24, 2014 at 10:46
  • no it doesn't work :-( \small doesn't resize minitoc.
    – Michele M
    Mar 24, 2014 at 10:55
  • OK. Could you create a minimal example, as described in wiki.lyx.org/FAQ/MinimalExample Then edit your post to include either the exported LaTeX (File --> Export --> LaTeX (pdflatex)), or the contents of the .lyx file itself. (Open the .lyx in a text editor, e.g. Notepad, copy everything, paste it into your question.) Mar 24, 2014 at 11:02
  • ok. I have done :-)
    – Michele M
    Mar 24, 2014 at 12:29

1 Answer 1

1

One alternative is to add tight as an option to the minitoc package, i.e.

\usepackage[tight]{minitoc}

This will set the minitocs with tighter vertical spacing, which will make it fit on one page.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .