1

I get the same error as reported here. An update of miktex did not help so I am at a loss as to how to proceed. The example works just fine on a different machine.

\documentclass{article}

\usepackage{multirow}
\usepackage{ntheorem} 
\usepackage{amsmath}
\usepackage{amssymb}
\usepackage{cancel}
\usepackage{tikz}
\usepackage{fontspec}
\usepackage{polyglossia}
\usepackage[shortlabels]{enumitem}

\renewcommand{\theenumi}{\hebrewnumeral{\value{enumi}}}
\renewcommand{\labelenumi}{\theenumi}

\theoremstyle{nonumberplain}
\setmainlanguage{hebrew} 
\newfontfamily{\hebrewfont}{Arial}



\newtheorem{thm}{משפט}
\newtheorem{prop}{טענה}
\newtheorem{lem}{למה}
\newtheorem{defin}{הגדרה}
\newtheorem{rmrk}{הערה}
\newtheorem{cor}{מסקנה}
\newtheorem{proof}{הוכחה}
\newtheorem{ex}{תרגיל}
\newtheorem{expl}{דוגמא}


\begin{document}
\title{שלום עולם}
\maketitle
\section{ניסיון}

%%\begin{thm}
%%גרף מישורי מקיים
%%$$
%%m \leq 3n-6
%%$$
%%\end{thm}

%\begin{enumerate}
%\item
$$
a_{i}^{'}=\begin{cases}
a_{i}& i \neq t\\
2t=b_{t}& i=t
\end{cases}
$$
ו-
$$
b_{i}^{'}=\begin{cases}
b_{i}& i \neq t\\
2t-1=a_{t}& i=t
\end{cases}.
$$
%\item
$$
a_{i}^{''}=\begin{cases}
a_{i}& i \neq t+1\\
2t=b_{t}& i=t+1
\end{cases}
$$
ו-
$$
b_{i}^{''}=\begin{cases}
b_{i}& i \neq t\\
2t+1=a_{t+1}& i=t
\end{cases}.
$$
%\end{enumerate}

\end{document}
4
  • You shouldn't be using $$...$$, but \[...\]. I get no errors after removing the % characters; more information about the system where XeLaTeX fails is necessary. What version of MiKTeX is running on it? – egreg Mar 24 '14 at 13:11
  • @egreg I tried [ but get the same error. ($$..$$ worked just fine on the other machine). Miktex is 2.9. What could be going wrong here? – Felix Goldberg Mar 25 '14 at 14:57
  • Add \listfiles and compile on both machines, then compare the lists to see where's the mismatch. – egreg Mar 25 '14 at 15:08
  • I didn't get any error with your example. Using MikTeX 2.9 (but not recently updated). Is it possible that some recent behavior change caused this? What other OS+TeX distro combinations have you tried? ... Also, please try to further reduce your example. – einpoklum Mar 25 '14 at 17:32