11

I am creating a presentation with Beamer, in which my references span more than one frame. In order to have the references automatically split in multiple frames I used the allowframebreaks parameter.

Also, I do not want to include the reference frames in the frame numbering. Therefore, I tried to ignore those frames with two different approaches:

By using addtocounter to decrement the total frame number

\begin{frame}[plain, allowframebreaks]
    \frametitle{References}
    \bibliographystyle{abbrv}
    {\tiny \bibliography{bibliography}}
    \addtocounter{framenumber}{-1}  % <---- HERE
\end{frame}

By using noframenumbering (available since v. 3.08) to simply ignore the frame

\begin{frame}[plain, allowframebreaks, noframenumbering] % <---- HERE
    \frametitle{References}
    \bibliographystyle{abbrv}
    {\tiny \bibliography{bibliography}}
\end{frame}

The problem I am facing is that just the first reference frame is being ignored, no matter the approach used. The additional ones (automatically split by the use of allowframebreaks) are always being accounted in the total frame number (checked with \inserttotalframenumber).

I would very much appreciate any help in pointing out what I am doing wrong. :)

3

I found this thread which is very similar to my problem, even though it is about appendix frames instead of bibliography frames.

Among the answers, this one indicates that the parameter noframenumbering is not inherited by the additional frames added by allowframebreaks and proposes to add the following code to the preamble:

\usepackage{etoolbox}
\makeatletter
\preto{\appendix}{%
  \patchcmd{\beamer@continueautobreak}{\refstepcounter{framenumber}}{}{}{}}
\makeatother

I tried to do something similar for my need (i.e. changing \appendix for \bibliography), but could not succeed. Errors like the following were presented, indicating that perhaps the \bibliography command does not have a similar structure to the \appendix command:

Argument of \bibliography has an extra } ...reak}{\refstepcounter{framenumber}}{}{}{}}

However, I tried this other answer that proposes to handle the frames as backup frames. First, it proposes to add the following macros to the preamble:

\newcommand{\backupbegin}{
   \newcounter{framenumberappendix}
   \setcounter{framenumberappendix}{\value{framenumber}}
}
\newcommand{\backupend}{
   \addtocounter{framenumberappendix}{-\value{framenumber}}
   \addtocounter{framenumber}{\value{framenumberappendix}} 
}

And then it proposes to use those macros to enclose the definition of the frames you do not want to have influence in the frame numbering.

So, I defined my reference frames like this:

\backupbegin
\begin{frame}[plain, allowframebreaks]
    \frametitle{References}
    \bibliographystyle{abbrv}
    {\tiny \bibliography{bibliography}}
\end{frame}
\backupend

And it all worked like a charm! The additional frames no longer are being accounted in the frame numbering. :)

P.S.: If somebody knows how to use the solution for the first answer referred to bibliographies, that would be very useful. It seems to me that that approach "feels" to be more correct.

  • The proposed solution still shows an increasing frame number in the frame number area. It is only hidden by the plain frame style. Any way to do this with a custom frame style? – elgicse Dec 15 '16 at 15:56
  • I honestly don't know, @elgicse. A plain frame was enough for my intention at the time, so I didn't test any further than that. – Luiz Vieira Dec 15 '16 at 16:32
  • 1
    For me, the first solution stops the numbering increasing during the reference slides, but includes the reference slides in the total frame count (so the last slide before references might look like 30/36, for example). The second solution doesn't count the reference slides for the total, but increases slide numbers during the references (so in the references, I get numbering like 32/30, 33/30, etc). If I combine both solutions in your answer, it works perfect. – Chester Apr 9 '18 at 13:02
  • 1
    I want to remark that the scheme is just record the pagenumber at the begining of bibliography and then reset the framenumber at the very end of document. So, the following code do the same thing: ``` \newcounter{framenumberend} \setcounter{framenumberend}{\value{framenumber}} \bibliography{your_bibtex_database} \end{frame} \setcounter{framenumber}{\value{framenumberend}} ``` – user19832 Feb 27 at 8:56
3

See More than one option within a frame.

The solution is to put this in the preamble: \setbeamertemplate{frametitle continuation}{} and only use allowframebreaks but not noframenumbering.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.