2

I've just installed Lyx 2.0.7.1 on Mac OS X (Mavericks) and when trying to type in Lyx, some keys behave irregularly. More specifically, typing some punctuation marks on my keyboard (such as period, colon, question mark and semicolon) does not result in those characters being inputed. Instead, diacritical marks (accent marks such as á) are inputed instead. This problem only occurs when I'm NOT in formula mode. My Lyx keyboard map is american (I've also tried american-2) and my keyboard layout in Mac OS X is U.S. (I've also tried U.S. PC). I also have hebrew on both my mac and Lyx but the problem happens when I'm in English on both.

EDIT: update. I've realised now that pressing the keyboard key twice actually produces the desired key. For example pressing period twice types period whereas pressing period and then a produces ȧ. Similarly, pressing SHIFT+semicolon/colon key and then semicolon/colon again produces colon etc. Still no explanation though as to why this is happening. Can't find any mention of it online

  • It seems it is worth a bug report to the maintainers of Lyx… – Franck Pastor Mar 25 '14 at 18:22
  • Strange. Never heard of this. I would suggest trying LyX 2.1 RC1 when it comes out in a few days. Also consider filing a bug report at www.lyx.org/trac – scottkosty Mar 26 '14 at 7:43
1

Ok, I know that I'm pretty late with the answer, but I just bumped into this problem. I solved it by changing the primary language (under preferences-> editing-> keyboard/mouse) to null enter image description here

Works perfectly now

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.