What I did...

First try. The readme-file of uarial says actually, it should be installed in


I downloaded the TDS directory, uncompressed somewhere, and then tried to copy to carpets where the files should likely to be placed: e.g.

  • /usr/share/texlive/texmf-dist/tex/ but also
  • /usr/share/texmf/

At that time, when I typed kpsewhich uarial.sty that file was in /usr/share/texlive/texmf-dist/tex/latex/. I compiled the code bellow, and I got no arial.

Second try. Then I installed the via "getnonfreefonts", and it says I have Arial istalled (not sure if it's the same as uarial though).

Installation directory: /home/<myself>/texmf
arial-urw      Arial (URW)                                  [installed]
[...]                                                       [installed]
webomints      Webomints (Galapagos Design Group)           [installed]

At that time kpsewhich uarial.sty said the file was located in /home/<myself>/texmf/tex/latex/ua1/uarial.sty. I compiled the code bellow, and I got no arial.

Third attempt. I installed as here says, according to comments below. In short,

I located the tree with kpsewhich --var-value=TEXMFLOCAL (mine was /usr/local/share/texmf/, which surprisingly, it only had a doc/ carpet) and unpacked there the content of the arial.tds.zip. I compiled the code bellow, and I got no arial.

I'm in Ubuntu 13.10 and installed the full latex package, if that says somehting.

Status now.

Question: My actual problem is that I want to use arial. So I tried to install uarial by some methods described below. I compile (with PDFLaTeX) following code, it renders no warning, no error whatsoever; but also no arial whatsoever.



Text here, which should be in arial, but isn't.


How to revert following errors and do the right installation?

(If it helps to bound the problem, slightly changing the code into


foo \textbf{bar}


which should work, as it comes from this answer, for me doesn't work.)

  • 1
    Try installing with getnonfreefonts, which is already part of TeX Live. – DG' Mar 26 '14 at 22:10
  • @DG' Ok, I did it. Now I installed all the fonts. Does it work for PDFTeX? // Oh, nice, it corrected the path of uarial.sty, now it's in ...texmf/tex/latex/ua1/uarial.sty, but it renders still the standard font. – c.p. Mar 26 '14 at 22:14
  • @JorgeCampos: Next time: Manual font installation. – Speravir Mar 27 '14 at 4:08
  • 1
    @JorgeCampos Clear out failed attempts from your personal texmf tree. – cfr Mar 27 '14 at 12:40


This shouldn't be in arial because it is in the default document font, which is roman.

Text here, which should be in arial because the package set the default sans family to arial.}

This isn't in arial again.


Now all is arial as the command isn't restricted by a group.

  • thanks, how am I supposed to compile this? I mean, with PDFLaTeX it renders error messages (and doesn't generate a pdf-file). With LaTeX I get no .dvi. With XeLaTeX, no problem, but it renders no output. – c.p. Mar 27 '14 at 7:10
  • 1
    @JorgeCampos If it doesn't compile, probably the font is not installed properly. But it is hard to say without knowing which error messages you get... By the way, my code is saying essentially the same thing as the code in the answer you linked to: uarial.sty only installs arial as the default sans family. You will still get regular Computer Modern or whatever for the roman/serif family (without changing the default family or switching to sans). – cfr Mar 27 '14 at 12:36
  • Well, the error is [PDFLaTeX] finished with exit code 1, then says 0 errors, 0 warnings, 0 badboxes but it generates no PDF. I get the same with this answer here. tex.stackexchange.com/a/140103/15542 – c.p. Mar 27 '14 at 13:35
  • Oh, I see. In on installing this time with getnonfreefonts-sty I only found an error regarding arial, i.e. "ERROR: The following map file(s) couldn't be found: arial.map (in /etc/texmf/web2c/updmap.cfg) Did you run mktexlsr?" – c.p. Mar 27 '14 at 13:39

I suppose the procedure is the same as under Windows. You should add this line in your updmap.cfg:

Map ua1.map

then run (perhaps texhash, and)updmap-sys in order to redo the psfonts database.

The right place to unzip your tds.zip file as far as I know is your local-texmf, which is created by TeX Live on installation. What the readme file says actually is that it should be placed right under a texmf root. With TeX Live, you have texmf-dist where the files from the official TeX Live distribution are put, and texmf-local(or so…) where your should put files you install yourself. This way, they do not risk to be overwritten on a TeX Live update.

  • 1
    The “local tree” location can be found by doing kpsewhich -var-value TEXMFLOCAL – egreg Mar 27 '14 at 0:08
  • Don't use updmap. Use updmap-sys. – cfr Mar 27 '14 at 0:45
  • @cfr: Ah! That's one of the slight differences with MiKTeX… Thanks, I change that in may answer. – Bernard Mar 27 '14 at 1:31
  • Hmmm, once again: Manual font installation. – Speravir Mar 27 '14 at 4:06
  • 1
    @JorgeCampos Get rid of the stuff in your personal texmf tree which has to do with uarial and run getnonfreefonts (with sudo or as root) to install it. This will be a lot easier as everything will be done automatically - you just will be asked which fonts you want installed so you can select them. The rest is magic ;). But make sure you clear out failed attempts at installation first to avoid possible confusion. – cfr Mar 27 '14 at 12:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.