1

I am having problems when I try to run bibtex with both TEXmaker and in the terminal. I'm using centOS.

In w8 everything runs ok, and I get the final pdf with correct references.

In Linux though, with TEXmaker I get

Error : could not start the command

when I try to compile, either by doing it manually or with quickbuild. I compile by doing latex+bibtex+latex+latex.

In the terminal my bash script looks like this:

export fi=Level2 export day=`date +%d%m%y`
cp $fi.tex OLD/$fi$day.tex
#clean  rm -rf  $fi.bbl $fi.aux $fi.blg $fi.dvi $fi.log $fi.pdf
latex $fi.tex bibtex $fi latex $fi.tex latex $fi.tex dvipdf $fi.dvi $fi.pdf
#okular $fi.pdf & gnome-open $fi.pdf &

Both the .bib and the .bst are in this directory. natbib is loaded by default, but if I call the packadge I get the same result.

\clearpage \bibliographystyle{model2-names} %%
\bibliography{./Bibtex/global} \bibliography{global_scat} \clearpage

I use Bibtex in Linux insted of biblatex because I need to be able to run the tex file both OS without major changes to it.

closed as off-topic by Martin Schröder, Svend Tveskæg, Thorsten, cmhughes, Jesse Mar 29 '14 at 14:55

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Is bibtex recognized as a command inside a terminal? – remus Mar 27 '14 at 11:44
  • It wasn't, I had two versions of latex installed, they were conflicting. now it works. thank you for the heads up. =) – user3250334 Mar 27 '14 at 13:17
  • Welcome to TeX.SX! Usually, we don't put a greeting or a “thank you” in our posts. While this might seem strange at first, it is not a sign of lack of politeness, but rather part of our trying to keep everything very concise. Accepting and upvoting answers is the preferred way here to say “thank you” to users who helped you. A suggestion: Do us a favour and change your username to something more telling than "user1234". – Martin Schröder Mar 29 '14 at 14:07
  • 4
    This question appears to be off-topic because it was caused by two conflicting TeX installations. – Martin Schröder Mar 29 '14 at 14:08
  • Why would needing to run the same file on both OSes stop you using biblatex? – cfr Mar 29 '14 at 14:16

Browse other questions tagged or ask your own question.