Figures are labeled as 1.0.1 but as I am only using "Parts" and do not have "chapters" or"sections" i would like them to be 1.1, 1.2 and so on.

  • Further more they should be labeled with the parts... 2.1 2.2 and so on – user48857 Mar 28 '14 at 23:16
  • What document class are you using? – Werner Mar 29 '14 at 0:49
  • Please post a Minimal Working Example so people can understand your setup. – cfr Mar 29 '14 at 2:12
  • It is a report (KOMA - Script). I've added "\setcounter{chapter}{1}" to get the numbers to start at one and not zero. I am using parts and unnumbered sections but not chapters. There are 3 parts in the document, each with (say) 3 figures. The figures are labeled 1.0.1 to 1.0.9 where I would like them to be as follows: 1.1, 1.2, 1.3, 2.1, 2.2, 2.3, 3.1, 3.2, 3.3 Thanks! – user48857 Mar 30 '14 at 17:15

Add to your Document > Settings... > LaTeX Preamble the following code:

\@addtoreset{figure}{part}% Reset figure numbering at every part
\renewcommand{\thefigure}{\arabic{part}.\arabic{figure}}% Figure number is part.figure

The default numbering of parts in KOMA-Script is Roman, so I've used \arabic{part} since. However, if you've updated this somehow to be Roman elsewhere, you could just use \thepart.\arabic{figure}.

| improve this answer | |
  • This is so close. The only problem now is that there is an extra period following the number. So it reads "1.1." which would be fine except there is an additional colon following it so it looks funny (1.1.:). Thanks! – user48857 Apr 1 '14 at 21:51
  • @user48857: You may wish to add \renewcommand*{\figureformat}{\figurename~\thefigure} to your LaTeX Preamble as well. This redefinition removes the default \autodot that follows \thefigure. Depending on your preference, you may not like the inconsistency between how the figure number is displayed in the actual float compared to the LoF, for example. – Werner Apr 1 '14 at 22:10

If what you want is to have figures numbered not following sectionning ! fig1 fig2 fig3!

And what you are getting is fig 0.1, fig 0.2 ...

Then what you need to do is to make sure the Number figures by section is not used in document > settings > modules!

And too use document class article (standard).

(on document > settings > document class)

The numbering will turn nice! Continous without sectionning!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.