I am so sure it is just a minor problem, yet I try to solve it since days without any progress, so I would be glad for any help:

I recently switched to biblatex - and my document fails to produce a bibliography and proper citations (it just gives the key in bold and brackets). I reinstalled everything several times but stll assume somehow biber does not run properly. I use Biber 1.8, Miktex 2.9 (32 bit) and Texniccenter.

So what I do:


blabla \cite{key}

My refs file does exist and is found, still I get the warnings:

Citation 'key' on page 1 undefined on input line 7.

Biber tells me:

This is Biber 1.8 - Logile is 'xy.blg' - Reading 'xy.bcf' - Found 42 citekeys in bib section o - Processing 0 - Looking for bibtex format file 'refs.bib' - Than a number of warnings (not parse correctly, Duplicate entry key...) - and then: BibTex subsystem: C\User... \AppData\LocalTemp\NJf6qjXqel\refs.bib_57752.utf8, line 1, warning: 9 characters of junk seen at toplevel and then an Error (all former = warnings) C\User... \AppData\LocalTemp\NJf6qjXqel\refs.bib_57752.utf8, line 5187, syntax error: found"(", expected","

So what do I do wrong??

Update: Problem was with the .bib file - imported automatically from Citavi.

  • 3
    What does biber output when you run it?
    – Juri Robl
    Mar 31, 2014 at 10:38
  • Welcome to TeX.SX! Usually, we don't put a greeting or a “thank you” in our posts. While this might seem strange at first, it is not a sign of lack of politeness, but rather part of our trying to keep everything very concise. Accepting and upvoting answers is the preferred way here to say “thank you” to users who helped you. Mar 31, 2014 at 10:39
  • Well, the error seems to indicate your .bib file is not well-formed. (Duplicate entry key does not sound too good). Can you perhaps narrow the problem down by selectively removing entries until the error goes away (go to those pointed to by the error message first).
    – moewe
    Mar 31, 2014 at 11:41
  • If biber gives an error, it stops trying. However it's always worth deleting all the generated files from trying to compile with (pdf)latex and biber as a quick test before digging too deep. After that the line number given in the error (usually) corresponds to the line number in your .bib (±1, or at least within the same entry), so look for blank fields, commas wrongly present/missing, mismatched brackets (does a field open with{ and close with " for example.
    – Chris H
    Mar 31, 2014 at 11:54
  • 4
    This question appears to be off-topic because it is about a problem that was solved when the input (detail not provided) was corrected. Mar 31, 2014 at 13:29

1 Answer 1


The option backend=biber doesn't tell LaTeX to run biber automatically, it merely tells biblatex what format it should expect the bibliography file to be created in. The warning tells you it couldn't find the key you refer to in that output of biber.

After the first run of latex on your file (for example document.tex) you should run biber document (where you replace document with the actual filename without the .tex extension. After that you run latex again and it should insert the correct citations.

In short the normal workflow is:

  • latex <document> (or pdflatex etc.)
  • biber <document>
  • latex <document>

Please note you have to run biber again if you change citations in your text. Also, a second run of latex after running biber might be necessary to update references if page breaks have changed due to added or removed citations.

  • I use TexnixCenter and I changed all BibTex-path to Biber, no matter how often I run it, no result. By "run" I mean using build (Bibtex and Latex-PDF) - or would I have to run it differently?
    – Manu
    Mar 31, 2014 at 11:26
  • 1
    Why biber x 2? I've been running it only once so far and I got expected results. In what situations do you need to run biber twice?
    – remus
    Mar 31, 2014 at 11:30
  • 3
    Start by trying what @hugovdberg suggests manually, i.e. not via TeXnicCenter. That way we can rule out any interesting features coming from the editor (saw that with a student laptop last week). If pdflatex+biber works from the command promt, then we can start figuring out what else is wrong. But for now, pelase take the editor out of the equation.
    – daleif
    Mar 31, 2014 at 11:38
  • @remus not sure why I said that, must have been a lack of coffee ;) fixed it :)
    – hugovdberg
    Mar 31, 2014 at 11:41
  • I am sort of a greenhorn so I did what I hope is correct: I did not use TecnicCenter but Texmaker and run pdflatex+ biber still the same problem. Why does the output tell me:BibTeX subsystem: C:\Users\manu\AppData\Local\Temp\bMoDX8ibNv\refs.bib_60916.utf8, line 1, warning: 9 characters of junk seen at toplevel ERROR - BibTeX subsystem: C:\Users\manu\AppData\Local\Temp\bMoDX8ibNv\refs.bib_60916.utf8, line 5187, syntax error: found "(", expected "," INFO - WARNINGS: 16 INFO - ERRORS: 1
    – Manu
    Mar 31, 2014 at 11:46

Not the answer you're looking for? Browse other questions tagged .