13
! Package babel Error: You haven't defined the language en yet

I am getting the above error - no matter what I do... I have tried everything from the other answers and am sure now that its not related: Package babel Error: You haven't loaded the option english yet, Language problems with biblatex and babel. Nothing is working. These are the errors:

! Package babel Error: You haven't defined the language en yet. See the babel package documentation for explanation. Type H for immediate help.

...

l.81 \select@language{en} Your command will be ignored, type to proceed ! Package babel Error: You haven't defined the language en yet. See the babel package documentation for explanation. Type H for immediate help.

...

l.89 \select@language{en} Your command will be ignored, type to proceed ! Package babel Error: You haven't defined the language English yet. See the babel package documentation for explanation. Type H for immediate help.

...

l.97 \select@language{English} Your command will be ignored, type to proceed ! Package babel Error: You haven't defined the language en yet. See the babel package documentation for explanation. Type H for immediate help.

...

l.105 \select@language{en} Your command will be ignored, type to proceed ! Package babel Error: You haven't defined the language jpn yet. See the babel package documentation for explanation. Type H for immediate help.

...

l.129 \select@language{jpn} Your command will be ignored, type to proceed ! Package babel Error: You haven't defined the language en yet. See the babel package documentation for explanation. Type H for immediate help.

...

l.137 \select@language{en} Your command will be ignored, type to proceed ! Package babel Error: You haven't defined the language en yet. See the babel package documentation for explanation. Type H for immediate help.

...

l.145 \select@language{en} Your command will be ignored, type to proceed ! Package babel Error: You haven't defined the language en yet. See the babel package documentation for explanation. Type H for immediate help.

...

l.153 \select@language{en} Your command will be ignored, type to proceed ! Package babel Error: You haven't defined the language en yet. See the babel package documentation for explanation. Type H for immediate help.

...

l.161 \select@language{en} Your command will be ignored, type to proceed ! Package babel Error: You haven't defined the language en yet. See the babel package documentation for explanation. Type H for immediate help.

...

l.169 \select@language{en} Your command will be ignored, type to proceed )

It doesn’t matter if I have this line or not:

\usepackage[english]{babel}

~~~~~~~~~~~~~~~~~~~~~ MWE ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

\documentclass{../frontiersstyle.sty/frontiersENG}

\usepackage{url,lineno}
\usepackage{textcomp} 
\usepackage{gensymb}

\usepackage{mathtools}
\usepackage{calc}
\linenumbers

\copyrightyear{}
\pubyear{}

\begin{document}

\bibliographystyle{../frontiersstyle.sty/frontiersinSCNS&ENG}

\cite{katsuyama_functional_2010}

\bibliography{refs}

\end{document}

closed as unclear what you're asking by egreg, Heiko Oberdiek, user31729, Masroor, jub0bs May 2 '14 at 10:52

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Welcome to TeX.SX! You can have a look at our starter guide to familiarize yourself further with our format. Moreover, it is hard to tell what is going wrong without looking at a minimal working example (MWE). – Ruben Mar 31 '14 at 11:46
  • 2
    Remove the .aux files, type \usepackage[english]{babel} and retry. The error is due to a preceding attempt with wrong options. – egreg Mar 31 '14 at 11:46
  • 1
    @egreg: I doubt it. You wouldn't get languages "en", "jpn" and "English" (uppercase) with the normal babel options. It is probably a faulty "language switching" command. – Ulrike Fischer Mar 31 '14 at 11:50
  • 2
    I had a similar issue and I solved it by removing language = {en} in bib file (or changing them to language = {english}). – Piotr Migdal Sep 3 '14 at 9:28
  • 1
    I had the same error. The solution was to delete language = {eng} from the bib entry, as @PiotrMigdal said. – jmjr Jul 15 '16 at 14:25
3

When you change what babel languages you use, it's good to remove the .aux file which contains things LaTeX saves from run to run, since it will contain lines that only work with the babel settings you had before.

If you rerun after removing the .aux file and get errors anyway they will have linenumbers, maybe pointing to lines where you do something like

\selectlanguage{SOMELANGUAGE}

where SOMELANGUAGE isn't mentioned in your babel settings.

From your error messages we can see you have called English "english" sometimes, and just "en" sometimes. The latter is incorrect. We can also see you at some time have tried to include Japanese. There is a question about writing Japanese here.

  • The presence of \select@language makes it highly unlikely that it refers to the main document, but rather to the .aux file. – egreg Mar 31 '14 at 17:58
  • True. I mostly wanted to alert ashley to the fact that these are strings that originally are from the document. – pst Mar 31 '14 at 18:08
  • Not changing languages at any point, include accents but that's about it language wise. I would like to remove babel all together, but then it fails to compile at all. – ashley Apr 1 '14 at 12:37
  • When it seems to not work "no matter what you do", there is a risk of changing several things at the same time, and not noticing the effect. Remove babel, since that's what you want. Remove the .aux files. (If you are unsure if you've removed all intermediary files, copy your TeX file to a new directory, to start from a clean slate.) Rerun. Then state more precisely what happens then, when it "fails to compile". – pst Apr 1 '14 at 13:11
  • @pst I removed babel and .aux and reran - the errors remain so it must be defining it somewhere else other than my main doc.. – ashley Apr 2 '14 at 8:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.