8

I am attempting to construct a Beamer presentation and I'm experiencing some difficulty. While I can insert a background image on the title slide using a "global setting", I don't want it to appear on every subsequent slide. Every subsequent slide (including the navigation/menu slide) should have a completely blue background with text of a currently undetermined color. Any help would be appreciated.

\documentclass{beamer}
\usetheme{Antibes}
\usepackage{graphicx}
\usepackage{tikz}

% \setbeamercolor{normal text}{fg=yellow}

\setbeamercolor{frametitle}{bg={}}
\title[...]{My title}

\usebackgroundtemplate{\includegraphics[width=\paperwidth, height=\paperheight]{08171830.jpg}}
\beamertemplatenavigationsymbolsempty
\date{}

\begin{document}

    \AtBeginSection[]
    {
        \usebackgroundtemplate{}
        \begin{frame}
            \setbeamertemplate{background canvas}[default]
            \frametitle{Outline}
            \tableofcontents[currentsection]
        \end{frame}
    }

    \begin{frame}
        \titlepage

    \end{frame}

    \section{Introduction}

    \usebackgroundtemplate{}
    \begin{frame}{History}
        This is a test page!
    \end{frame}

\end{document}
  • Welcome to TeX.SX! Your post was migrated here from another Stack Exchange site. Please register on this site, too, and make sure that both accounts are associated with each other (by using the same OpenID), otherwise you won't be able to comment on or accept answers or edit your question. – Speravir Apr 1 '14 at 0:21
  • Usually, we don't put a greeting or a “thank you” in our posts. While this might seem strange at first, it is not a sign of lack of politeness, but rather part of our trying to keep everything very concise. Accepting and upvoting answers is the preferred way here to say “thank you” to users who helped you. Also you don't have to sign with your name since it automatically appears in the lower right corner of your post. – Speravir Apr 1 '14 at 0:23
7

With \setbeamertemplate{title page}{...} you can modify the title page without effecting global setting.

\documentclass{beamer}
\usetheme{Antibes}
\usepackage{graphicx}
\usepackage{tikz}

\pgfdeclareimage[width=\paperwidth]{mybackground}{back.pdf}

\setbeamertemplate{title page}{

        \begin{picture}(0,0)

            \put(-30,-163){%
                \pgfuseimage{mybackground}
            }

            \put(0,-110.7){%
                \begin{minipage}[b][45mm][t]{226mm}
                    \usebeamerfont{title}{\inserttitle\par}
                \end{minipage}
            }

            \end{picture}

    }

\title[...]{My title}

\begin{document}

    \begin{frame}[plain]
        \titlepage
    \end{frame}

    \section{Introduction}

    \begin{frame}{History}
        This is a test page!
    \end{frame}

\end{document}

enter image description here

| improve this answer | |
  • 1
    Using \usebackgroundtemplate{} just before \begin{frame} worked for me. – Hirak Mar 27 '16 at 6:26
  • @Hirak If you have an alternative solution, please consider positing it as an answer, more people will see it. – samcarter_is_at_topanswers.xyz Mar 27 '16 at 10:02
  • @Hirak: that puts it on every slide, not? – Victor Eijkhout Jun 15 '16 at 15:44
11

Enclosing \usebackgroundtemplate by { ... } applies the command within the scope. Place your title page frame within the scope like so:

\documentclass{beamer}
\usetheme{Antibes}
\usepackage{graphicx}
\usepackage{tikz}

\title[...]{My title}
\begin{document}
{
  \usebackgroundtemplate{\includegraphics[width=\paperwidth]{back.pdf}}
  \begin{frame}
    \titlepage
  \end{frame}
}

\begin{frame}{History}
    This is a test page!
\end{frame}

\end{document}
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.