4

When I compile my document using XeLaTeX I get the following error:

** WARNING ** Can't begin an annotation when one is pending.
** WARNING ** Interpreting special command bann (pdf:) failed.
** WARNING ** >> at page="6" position="(232.638, 77.032)" (in PDF)
** WARNING ** >> xxx "pdf:bann<</Type/Annot/Subtype/Link/Border[0 0 0]/C[0 1 0]/A<..."
** WARNING ** >> Reading special command stopped around >><</Type/Annot/Subtype/Link/Border[0 0 0]/C[0 1 0]/A<</S/GoTo...<< 
** WARNING ** Tried to end an annotation without starting one! 
** WARNING ** Interpreting special command eann (pdf:) failed. 
** WARNING ** >> at page="7" position="(94.9061, 708.045)" (in PDF) 
** WARNING ** >> xxx "pdf:eann"

Any thoughts of why I get this error?

Update 1: There seems to be a "collision" between XeLaTeX and hyperref. The problem is solved when you use pdflatex, but how about xelatex? Is there any hope?

Update 2: I had a \section{smth} that was empty for I will prepare it later, something like an intro in the main paper, but I just wanted to have it there for future reference. Now, I am doing some work on what follows. It seems that XeLaTeX and hyperref do not like this kind of behaviour though. Now, when you start writing in this section the problem disappears. However, I do not know if this one counts as a an answer to the problem. I leave that to the mods to decide.

Update3: (I am sorry if I make you tired). Now, I think, I understand the problem. It is a combination of Update 2 and half-finished paragraphs. That is in a previous section(just before what I mention in Update 2) there is another one that has two paragraphs. The first one is finished, but the second is not. Actually it only has a small sentence. It seems that after you use par a certain number of characters must be filled (I do not know the exact number, but I tried with different lengths and it works after a specific threshold). I also tried with pdflatex, but it works fine with it.

closed as unclear what you're asking by Ian Thompson, user31729, yo', lockstep, Paul Gessler Jul 31 '14 at 20:29

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Without a MWE, which may be difficult to create, you're probably going to have to answer your own question. – jon Apr 1 '14 at 0:21
  • @jon I think so :( I need to find out what creates this conflict. – Pantelis Kazakis Apr 1 '14 at 0:22
  • Really weird! In the paragraph that the problem is found, if I erase/delete words arbitrarily, more than 4, the warning disappears. I have never seen that before. This makes me think that there is something in the paragraph that I cannot see ... – Pantelis Kazakis Apr 1 '14 at 0:56
  • It's very hard without a MWE. Just shooting at the air here, but check this out: groups.google.com/forum/#!topic/comp.text.tex/fR9Y_e6Zo5E. Disable hyperref and check if the problem is gone. – Nico Apr 1 '14 at 1:22
  • 3
    I suspect links broken across pages, e.g. in a footnote, with links in header/footer or somethink like this. I do not know a driver that fully supports page breaks in links. I do not think, an "empty" section is related to the problem. Rather the page breaking changes by adding stuff moving the links to safer locations. – Heiko Oberdiek Apr 1 '14 at 3:30

Browse other questions tagged or ask your own question.