4

I'm using chemstyle to create a list of schemes and also tocloft. I noticed that the whitespace above the List of Schemes header is larger than the whitespace above the Table of Contents and List of Figures headers. Is there a way to customize the whitespace above the los header (or the toc and lof headers) so it's consistent?

MWE:

\documentclass[oneside, 12pt, a4paper]{book} 
\setlength\headheight{15pt}
\usepackage[varioref=false]{chemstyle}
\usepackage{caption} %required for chemstyle
\usepackage{psfrag}
\usepackage{tocloft}

\begin{document}

\frontmatter
\tableofcontents
\cleardoublepage
\listoffigures
\cleardoublepage
\listofschemes

\end{document}
3
  • Welcome to TeX.SX! Commented Apr 2, 2014 at 7:05
  • Does my answer solve your problem? Commented Apr 2, 2014 at 8:34
  • Yes, your solution works as expected for me. Thanks very much for your help!
    – aller17
    Commented Apr 7, 2014 at 15:43

1 Answer 1

4

The culprit of this behavior is the tocloft package.

Adding the option titles when loading it:

\usepackage[titles]{tocloft}

causes the titles of the custom lists to be typeset using the default LaTeX methods, and so your problem is resolved.

MWE (note that there's no need to load caption since it is loaded by chemstyle):

\documentclass[oneside, 12pt, a4paper]{book}
\setlength\headheight{15pt}
\usepackage[varioref=false]{chemstyle}
\usepackage{psfrag}
\usepackage[titles]{tocloft}

\begin{document}

\frontmatter
\tableofcontents
\cleardoublepage
\listoffigures
\cleardoublepage
\listofschemes

\end{document} 

Output:

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .