7

I need the same positioning of footnotes marks and text as produced by using \usepackage[hang]{footmisc} (footnote mark close to the left margin, some space between mark and text and the same space between the text and the left margin for all the lines). I also need to make hyperlinks to the footnotes. Since footmisc and hyperref packages don't work well together (i.e. no hyperlinks to footnotes are produced), is it possible to specify mentioned positioning without using footmisc package? Or is there any other way to accomplish both desired positioning and linking?

Here is the working example of what I want to accomplish, just with the working hyperlink:

% Compiled using XeLaTeX.
\documentclass[a4paper, 11pt, twoside, openright]{report}
    \setlength{\parindent}{0pt}
    \setlength{\parskip}{12pt}
\usepackage[nodisplayskipstretch]{setspace}
\usepackage[hidelinks,colorlinks=true,linkcolor=blue,citecolor=blue,urlcolor=blue]
           {hyperref}
\usepackage[hang]{footmisc}
    \setlength\footnotemargin{12pt}

\begin{document}
\section{This is the title}
    This is some text with the footnote\footnote{And this is the footnote formated
    exactly as I like, but it would be perfect if the hyperlink in the main text
    would work as it does when I do not use the footmisc package.}.
\end{document}
7
  • Welcome to TeX.SX! Please help us to help you and add a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}.
    – user31729
    Apr 2, 2014 at 12:36
  • 1
    If you load the hyperref package after the footmisc package, you should be getting footnote markers that are hyperlinks to the corresponding footnotes. (Aside: Because hyperref has to perform various demanding jobs to convert the cross-reference call-outs, incl. footnote markers, it's important to load it after any package that also affects LaTeX's cross-referencing abilities. The only major exception to this rule is the cleveref package: it should be loaded after hyperref.)
    – Mico
    Apr 2, 2014 at 13:09
  • 1
    Thanks, @Mico! It works perfectly! I just wonder why they didn't write this in the footmisc package documentation instead of the recommendation to use the hyperref package with the option hyperfootnotes=false.
    – MMSt
    Apr 2, 2014 at 13:18
  • Well, it's sort of common LaTeX lore that certain packages should not be loaded after hyperref. I'll write up an answer that makes this all a bit more explicit.
    – Mico
    Apr 2, 2014 at 13:20
  • 1
    Well, IIRC, the main incompatibility between footmisc and hyperref has to with the former package's option multiple: If only footmisc is loaded, the multiple option works fine, but if the hyperref package is loaded as well, the multiple option doesn't perform properly. See Incompatibility between footmisc-option multiple and hyperref for more information.
    – Mico
    Apr 2, 2014 at 13:40

2 Answers 2

10

Your document's footnote markers currently aren't active hyperlinks to the corresponding footnotes because you're loading footmisc after hyperref. If you load footmisc before hyperref, you should get the expected behavior.

Because hyperref has to perform various demanding jobs to convert the cross-referencing call-outs, incl. footnote markers, into hyperlinks, it's important to load it after most packages that also affect LaTeX's cross-referencing abilities. A major exception to this rule is the cleveref package: it must be loaded after hyperref.

For more information on which packages should be (or must be) loaded after hyperref, see the posting Which packages should be loaded after hyperref instead of before?


Addendum: Your claim that the "footmisc and hyperref packages don't work well together" appears to be based, in part, on a reading of the user guide of the footmisc package, which states on p. 7 that

The hyperref package has ambitions to make hyperlinks from footnote marks to the corresponding footnote body; naturally this causes grief to footmisc, and unfortunately no remedy is currently known. If you use footmisc, suppress hyperref's hyper-footnotes, by loading it as:

\usepackage[hyperfootnotes=false,...]{hyperref}

These statements appear to be based on older versions of the two packages. Fortunately, the situation is no longer that bad. In fact, it has been quite good for at least a few years. The only remaining major negative interaction between the two packages that I'm aware of occurs if the multiple option of the footmisc package is loaded. (If this option is set, LaTeX is supposed to insert a raised comma automatically between consecutive footnote marks.) This option doesn't work if the hyperref package is loaded. :-( For more on this vexing topic, see the TeX.SE posting Incompatibility between footmisc-option multiple and hyperref.

0

All footnotes package must be declared after loading hyperref, for the hyperlinks to work same goes for bigfoot. When using tabularx alongwith with hyperref, load tabularx after hyperref. I would suggest loading tabularx alongwith hyperref initially to avoid conflicts as hyperref needs to be applied throughout.

1
  • 1
    The first claim is clear, but later the question becomes confusing, at least for me. What do you mean? Can you develope?
    – iago
    Nov 19, 2019 at 14:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .