6

When using esvect (MiKTeX, pdflatex) I get the following undesirable result:

esvect pixelated arrow

From this:

\documentclass{article}
\usepackage{esvect}
\begin{document}
\[\vv{u}\]
\end{document}

The arrows are pixelated in SumatraPDF and Adobe Reader, so it's not viewer related.

I suspect it's a font issue, but I am unable to problem solve much further than that.

4
  • No problem. \documentclass{article} \usepackage{esvect} \begin{document} [\vv{u}] \end{document} i.sstatic.net/kjeEF.png Apr 2, 2014 at 14:58
  • Can you report whether you see any warnings in your .log? Also read the final paragraph under section 1 Installation of the esvect documentation.
    – Werner
    Apr 2, 2014 at 15:10
  • @WeirdstressFunction Do you have a recently updated MiKTeX? Emphasis on recently.
    – Speravir
    Apr 3, 2014 at 19:48
  • @Werner: An installation as described in package documentation should be not necessary, because it could be installed with the package manager of MiKTeX. But in the moment there’s a bug: Upon latest update in November last year the map file was not added to installation file.
    – Speravir
    Apr 4, 2014 at 16:25

1 Answer 1

7

Update:
The following is now historical. The bug was fixed with MiKTeX update from 2014-04-10, cf. regarding entry in MiKTeX Bug Tracker: Map file missing for "esvect".


There is a very simple reason: MiKTeX installs all of esvect, except esvect.map, that is required to use the type 1 versions of the fonts. It actually exists in esvect-src.tar.bz2, but the simplest thing to do is to download the map file from here, for instance, and install it in Your_local_TeXMF\fonts\map\dvips\esvect.

As MiKTeX does not create a local TeXMF by default, create one if you haven't done it yet – with all the subdirectories mentioned above. Then:

  1. refresh the FNDB via MiKTeX Settings

  2. check if the file "updmap.cfg" in …\MiKTeX\2.9\miktex\config contains this line: Map esvect.map. If it does, jump to step 4.

  3. if it doesn't, write the line in your personal updmap.cfg, which should be located in C:\Users\YourName\AppData\Roaming\MiKTeX\2.9\miktex\config

  4. run updmap so as the refresh the database of type 1 fonts.

Actually for esvect, you won't have to go through step 3, but I preferred to describe the general procedure. It is also valid for fonts that you would install by yourself.

You will find much more detailed explanations in Create a local texmf tree in MiKTeX, to be adapted with the actual path names in your version of Windows (I gave the paths for Windows 7 Pro).

4
  • There are several fonts for which, even if their .map file is installed, MiKTeX forgot to run updmap. Btw, I've added a detail to my explanation: sometimes there's one more step.
    – Bernard
    Apr 2, 2014 at 16:54
  • Maybe one should call to the people to have a list of those fonts that lack something (mainly .map file not installed) in MiKTeX. I'm not sure whether installing a font from the Package Manager, even if the .map files exists includes launching updmap.
    – Bernard
    Apr 3, 2014 at 20:29
  • Usually updmap is called. I have successfully installed fonts with the Package manager. Much more obscure are BTW these cases where a map exists, but nonetheless no activation is done.
    – Speravir
    Apr 3, 2014 at 21:27
  • Just for your information: Bug filed in MiKTEX Bug Tracker: Map file missing for "esvect".
    – Speravir
    Apr 4, 2014 at 16:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .