1

I am aware that many questions have already appeared here regarding the indentation of the first paragraph, but I did not find any on this precise problem.

I am writing a document with some portions in French and others in English. My understanding of typographic rules is that in English the first paragraph of a chapter should not be indented, but it should be in French.

Now this is usually well taken care of by babel, which changes the rule accordingly depending on whether I load french or english. But when I load both, it uses the rules of the second one throughout the whole document, even in the parts where I input

\selectlanguage{french} or \begin{otherlanguage}{french} Lorem Ipsum  \end{otherlanguage}.

Of course I could correct it by hand, but it is slightly disappointing. Is there someway to tell babel to apply the correct indentation settings when I switch the language ?

  • Maybe you should load French as 1st language? Note that this french typograhic rule is not as universal as one might think, neither in history (until the end of the 18th century, the first line of a chapter usually was not indented, but began with a big capital letter – not a lettrine strictly speaking, as it had the same base line as the following letters), nor in our times: see Yves Perrousseaux, Mise en page et Impression, where he questions this "rule". – Bernard Apr 4 '14 at 17:05
  • I agree this is debatable, but that's how I would like it to be :) Changing the first language only changes the rule used throughout the text, but does not help switching it. – Arnaud Apr 4 '14 at 17:07
3

The documentation to frenchb makes clear that it's intentional. Some settings change with the language, and some are consistent in the document depending on the document language (p. 2).

Page 4 says it has been different, and that there is a setting that "should no longer be used" that emulates this. It does work though, if your main language is French:

\documentclass{article}
\usepackage[american,french]{babel}
\frenchbsetup{GlobalLayoutFrench=false}
\usepackage{blindtext}

\begin{document}
\begin{otherlanguage}{american}
\section{In English}
\blindtext
\end{otherlanguage}

\section{En fran\c{c}ais}
\blindtext

\end{document}

enter image description here

The alternative package frenchle changes this from language to language apparently, so this gives similar output:

\documentclass{article}
\usepackage{frenchle}
\usepackage{blindtext}

\begin{document}
\begin{english}
\section{In English}
\blindtext
\end{english}

\section{En fran\c{c}ais}
\blindtext

\end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.