3

This is not specifically a TeX question, but I think it might be relevant here since all TeX users are also text editor users.

I use the Emacs Aquamacs (v 3.0a) text editor. My locale on my Mac is Australian. As far as I understand Emacs applies in checking the spelling the current locale of the system is running on. I want to edit a document to be sent in the US and I then would like to change the dictionary from Australian (or British) to American English but just for one document.

I tried to navigate the Aquamacs documentation but without much success. It seems that the default Flyspell dictionary in my Aquamacs preferences is Standard. I couldn't find any indication to the actual dictionary file Aquamacs is using and how to change it.

EDIT: In my ~/Library/Spelling I have these dictionaries: en, en_au, en_GB, es, it, LocalDictionary. I can select any of these dictionaries through Edit -> Spelling -> Change dictionary... but without any effect in the words identified as wrong by the editor. I still get all US spellings checked as wrong (e.g. "organization", "behavior") but even selecting en as dictionary all Italian and Spanish words are not checked as wrong (e.g. alcalde, zorro, popolazione). It seems it is checking against all three dictionaries: british english, italian and spenish but not american english...

closed as off-topic by Heiko Oberdiek, Martin Schröder, Svend Tveskæg, Jesse, Adam Liter Apr 6 '14 at 23:17

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center." – Heiko Oberdiek, Martin Schröder, Svend Tveskæg, Jesse, Adam Liter
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Spell-Checking. Aquamacs spell-checks your documents with the OS X spell-checker, supporting more than a hundred languages and system-wide user dictionaries. aquamacs.org/features.shtml Open up System Preferences on OSX . . . Language & Text and select from the Language tab. The user personal dictionary is stored at: ~/Library/Spelling/LocalDictionary – lawlist Apr 7 '14 at 15:14
2

You can change the dictionary with M-xispell-change-dictionaryRET. It's also possible to select the dictionary using the menu Tools > Spell Checking > Change Dictionary....

In addition, you can specify the spelling language on a per-file basis with the file local variable ispell-local-dictionary, whose description (C-h v ispell-local-dictionary RET) reads

If non-nil, the dictionary to be used for Ispell commands in this buffer. The value must be a string dictionary name, or nil, which means use the global setting in ispell-dictionary. Dictionary names are defined in ispell-local-dictionary-alist and ispell-dictionary-alist.

Setting ispell-local-dictionary to a value has the same effect as calling M-x ispell-change-dictionary with that value. This variable is automatically set when defined in the file with either ispell-dictionary-keyword or the Local Variable syntax.

Thus, for example

%%% Local Variables:
%%% mode: latex
%%% ispell-local-dictionary: "american"
%%% End:

sets the dictionary to be used to american.

If you want to create a shortcut to change the dictionary to a specific language see the question Changing language of flyspell (Emacs) with a shortcut. In order to set the spelling dictionary according to the default babel language see https://www.gnu.org/software/auctex/manual/auctex.html#Style-Files-for-Different-Languages.

  • I can't seem to find any "american" dictionary though... Indeed I see only one "English" dictionary. – Francesco Apr 6 '14 at 21:33
  • @Francesco It was just an example, you have to check the dictionaries actually available in your system. – giordano Apr 6 '14 at 22:19
  • 1
    Aquamacs uses the native OSX spellchecker, which has the user personal dictionary stored at: ~/Library/Spelling/LocalDictionary Therefore, the spell check settings of the original poster need to be OS system wide -- open up System Preferences on OSX . . . Language & Text and select from the Language tab. – lawlist Apr 7 '14 at 15:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.