5

There are in Tipa package two options: \schwa which makes slanted “schwa” of a peculiar size, and \textschwa which adjust to the text-size (for example when in \textsuperscript, it gets the right dimension), but unfortunately is not slanted. How to get a slanted schwa sign in superscript?

\documentclass[a4,pdftex,dev]{book}
\usepackage[noenc]{tipa}
\begin{document}
\textit{ahmiia zaoth etc}\textit{\textsuperscript{{\textschwa}}}
\end{document}

1 Answer 1

6

The font is respected if you use a better syntax:

\documentclass{book}
\usepackage{tipa}
\newcommand{\upschwa}{\textsuperscript{\textschwa}}

\begin{document}
\textit{ahmiia zaoth etc\upschwa}

ahmiia zaoth etc\upschwa

\end{document}

enter image description here

Note though that the TIPA fonts don't have italics, but only slanted.

Loading tipa with noenc would give infinite recursion, so it's better to omit the option. Also a4 and dev are not options for the book class, you probably meant a4paper and draft; the option pdftex should never be specified.

4
  • I’ve copied that macro but it does not produce the same results on my machine: it displays the same superscript-size, but un-slanted schwa, in both instances.
    – Julieta
    Apr 6, 2014 at 12:48
  • @Julieta What TeX distribution are you running?
    – egreg
    Apr 6, 2014 at 13:30
  • @ egreg It is TeX Live 2012.
    – Julieta
    Apr 6, 2014 at 15:09
  • @Julieta I tried also with TeX Live 2012 and get the same result.
    – egreg
    Apr 6, 2014 at 15:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .