1

For my submission of an abstract using the required abstract template of the Association of Symbolic Logic (http://aslonline.org/abstractresources.html) I do not get the intersection sign properly. Here is my minimal example, but the asl.cls-file provided by the link is needed for compilation:

\documentclass[bsl,meeting]{asl}

\usepackage [greek, english]{babel}
%\usepackage{amssymb}
%\usepackage[utf8]{inputenc}
%\usepackage[T1]{fontenc}
%\usepackage{textcomp}

%\usepackage{amsmath}
%\usepackage{amsfonts}

\AbstractsOn

\pagestyle{plain}

\def\urladdr#1{\endgraf\noindent{\it URL Address}: {\tt #1}.}


\newcommand{\NP}{}
\usepackage{verbatim}
\usepackage{teubner}





\begin{document}

$\cap$

\end{document}
  • 1
    Shouldn't that be inside $s? – Bakuriu Apr 6 '14 at 14:42
  • I tried that as well, of course. But I will edit that for clarity. – Sapiens Apr 6 '14 at 14:44
  • I get an error due to teubner, but the intersection symbol is there. – egreg Apr 6 '14 at 15:09
  • @egreg tex.stackexchange.com/a/169667/39222. The OP has an outdated version of babel. If your babel is current, the preamble addition avoids the error. But that obviously raises the question of whether some other package causes the missing symbol in TL 2012 despite its working fine with TL 2013 (or whatever you are using). – cfr Apr 6 '14 at 15:13
  • @cfr It appears that teubner is not compatible with amsart, which asl.cls is based on. – egreg Apr 6 '14 at 15:16
4

The solution, I think, is to update your TeX installation. However, as your other question shows, updating may not be without pitfalls of its own.

I think it might be worth asking yourself just how much you need teubner. If it is only for the odd character (e.g. \koppa), I would think about whether there might be other ways to access those characters.

The particular version of teubner which you are using essentially screws up typesetting the intersection symbol. I ran diff -Naur to compare the final version of teubner in TeX Live 2012 with the current 2013 version. Here is a small part of the output:

-\DeclareTextCommand{\cap}{\GRencoding@name}{\cap@}
-\DeclareTextCommand{\cap}{OT1}{\cap@}
-\DeclareTextCommand{\cap}{T1}{\cap@}
-
+\let\mcap\cap
+\DeclareTextCommand{\tcap}{\GRencoding@name}{\cap@}
+\DeclareTextCommand{\tcap}{OT1}{\cap@}
+\DeclareTextCommand{\tcap}{T1}{\cap@}
+\DeclareRobustCommand*\cap{\textormath{\tcap}{\mcap}}

So basically, it seems that teubner was overriding the definition of \cap. This is why you get a complaint about any attempt to use $\cap$ that the command cannot be used in maths mode (?!). Running it outside maths mode works but does not produce the intersection symbol:

teubner's \cap

\documentclass{article}
\usepackage [greek, english]{babel}
\usepackage{teubner}

\begin{document}

\cap

\end{document}

Note that this is solely a function of teubner and has nothing to do with any conflict with asl. teubner conflicts with the basic definitions of maths symbols set up by LaTeX.

You can work around this particular problem by saving the value of \cap before loading \teubner and then inserting the code from the updated version after \teubner is loaded:

\documentclass{article}
\usepackage [greek, english]{babel}
\let\mcap\cap
\usepackage{teubner}

\makeatletter
  \DeclareTextCommand{\tcap}{\GRencoding@name}{\cap@}
  \DeclareTextCommand{\tcap}{OT1}{\cap@}
  \DeclareTextCommand{\tcap}{T1}{\cap@}
  \DeclareRobustCommand*\cap{\textormath{\tcap}{\mcap}}
\makeatother

\begin{document}

$\cap$

\end{document}

intersection despite teubner

However, there are all kinds of other nasties lurking here which are likely to cause unexpected output in a range of cases. Working around them one by one is likely to be a frustrating exercise. Updating is a better option. Although the current version of teubner is not unproblematic, it does seem to resolve some of the basic issues affecting you here.

To get the latest version, install TeX Live 2013 and then update the installation to ensure you get the December release of teubner. You could try just downloading the updated teubner from ctan and using that with your current installation. However, that might cause issues of its own.

If you do update, you should bear in mind that you may need my answer to your other question. Given egreg's comments here, this might have unforeseen side-effects but it does allow both the intersection symbol and \koppa to be typeset in the same document. As I say, if you can possibly dispense with teubner, that would surely be the cleanest solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.