I'm working with TexMaker

I made a bibliography.bib file and I've put in in the same folder as my .tex files (I've tried making a .bib file by hand and with BibDesk, but neither work).

In my project.tex file I put

some text \cite{evocomp}
some more text

And my bib file looks like this (I've only made one reference so far...):

Author = {name},
Date-Added = {2014-04-06 17:32:05 +0000},
Date-Modified = {2014-04-06 17:34:26 +0000},
Journal = {Methods},
Pages = {39-55},
Title = {some title},
Volume = {62},
Year = {2013}}

then I compile once as Latex and then as Bibtex and this is where is goes wrong.

I get the following message:

bibtex: Need exactly one file argument. Try `bibtex --help' for more information.

Does anyone have any idea what I'm doing wrong?

For your information I'm working with OS X Mavericks (so also just tell me if latex just doesn't work at all with this...)

UPDATE my problem is solved now, there was something wrong with the bibtex command in my preferences so texmaker couldn't find my .bib file.

closed as off-topic by Mico, cmhughes, dustin, user31729, T. Verron Sep 7 '14 at 20:23

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Welcome to TeX.SX! Do you have \cite commands in your document? And how are you running bibtex? Turning this into a complete minimal (non-)working example would be helpful. – Adam Liter Apr 6 '14 at 18:28
  • I changed my example a bit, so I hope it's better now, as you can see I did add a \cite command. I don't really know what you mean by how am I running bibtex, I've installed the MacTex 2013 package if that's what you mean, but if I need to install something else as well, that could maybe be my problem? – Chocolate_Althea Apr 6 '14 at 19:53
  • You need to say on the commandline: bibtex <filename> or bibtex <filename>.aux, where <filename> is the name of your .tex file. So: given a myfile.tex. I do: latex myfile, bibtex myfile, latex myfile, latex myfile. (The extensions are implicitly understood to be myfile.tex, myfile.aux, myfile.tex, myfile.tex.) – jon Apr 6 '14 at 19:53
  • In the Texmaker settings, what does the BibTeX command look like? – Torbjørn T. Apr 6 '14 at 20:55
  • 4
    This question appears to be off-topic because it is about a configuration error that the OP was able to solve on his/her own. – Mico Sep 7 '14 at 19:12

In Texmaker's settings, the BibTeX command reads

"/usr/texbin/bibtex" % .aux

but it should be

"/usr/texbin/bibtex" %.aux

without the space between % and .aux.

Not the answer you're looking for? Browse other questions tagged or ask your own question.