1

I am getting duplicates of my glossary and contents titles as shown below. How can I get rid of the first one?

Most of my preamble is shown below.

\documentclass[11pt, a4paper]{article}
\usepackage{graphicx,pgfplots,pgfplotstable, acronym, fullpage, booktabs, rotating, multirow, longtable, siunitx, fancyhdr, filecontents, textcomp, gensymb,pdfpages, amsmath, caption, subcaption}
\usepackage[parfill]{parskip}           % Remove indentation
\usepackage[titletoc, page]{appendix}   % To number appendix in toc
\usepackage[section]{placeins}          % To stop figures floating across sections
\usepackage[hidelinks]{hyperref}        % For clickable urls
\usepackage{cleveref}                   % To allow \cref to be used
\usepackage[T1]{fontenc}                % Use EC fonts
\usepackage[utf8]{inputenc}             % Encoding
\usepackage{csquotes}                   % To manage quotes
\usepackage[english]{babel}             % Language selection
\usepackage[acronym,toc,style=tree, nonumberlist, shortcuts]{glossaries}
\usepackage[backend=biber, citestyle=authoryear,doi=true,url=true]{biblatex}
  • 2
    Welcome to TeX.SE! Could you please also show the commands you use to generate the table of contents and the glossary? Ie., please don't show the preamble but provide a small working example that generates the problem behavior that needs to be fixed. Incidentally, since you provide the option toc while loading the glossaries package, you're guaranteed to get a ToC entry for the glosssaries section; do you maybe want to suppress this behavior? – Mico Apr 7 '14 at 6:34
  • Yes, removed the toc. Also, while trying to create a 'small working example' I discovered the problem. I was using \pagestyle{fancyplain} which was causing this problem. To remove the duplicate title in the header all I had to do was to modify this to: \pagestyle{fancyplain} \fancyhead{} – bluprince13 Apr 7 '14 at 7:11
  • What do I do now btw? Do I delete the question? – bluprince13 Apr 7 '14 at 7:20
  • I suggest you post an answer to your own question, in which you post the solution you found. – Mico Apr 7 '14 at 7:57
1

The use of

\pagestyle{fancyplain}

caused this problem. If you are using the fancyhdr package to define headers/footers yourself, you need to clear the default layout by declaring

\fancyhead{}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.