0

I am busy writing my dissertation. I am using Sublime Text 3 to edit the documents and Skim as the PDF viewer. There are several reasons why I am not using LaTeXing/LaTeXTools to compile:

  1. The document uses Tikz and Tikzexternalise and this was causing issues when trying to build.
  2. I am hosting the project on Github so that my supervisor and colleagues can get the source as and when needed.
  3. The project needs to be stand-alone.

Therefore I created a makefile that I keep in the directory and wrote a simple sublime-build script as seen below:

{
"shell":true,
   "cmd": ["make all"],
   "file_regex": "^(..[^:]*):([0-9]+):?([0-9]+)?:? (.*)$",
   "working_dir": "${project_path:${folder:${file_path}}}",
   // "selector": "source.makefile",
   "path": "/usr/texbin:/usr/local/bin:/Applications/Xcode.app/Contents/Developer/usr/bin:/usr/bin:/bin",

   "variants":
    [
      {
        "name": "Clean",
        "cmd": ["make clean"]
      },
      {
        "name": "Superclean",
        "cmd": ["make superclean"]
      },
      {
        "name": "View",
        "cmd": ["make view"]
      },
      {
        "name": "Help",
        "cmd": ["make help"]
      },
      {
        "name": "Continuous",
        "cmd": ["make cont"]
      }
    ]
}

The makefile is working perfectly. It is basically calling latexmk -f -cd -pdflatex=lualatex -pdf -quiet -synctex=1 -outdir=Output -shell-escape main.tex

The problem is that the forward and inverse search between Sublime Text and Skim is not working. Any ideas as to why? Have I done something fundamentally stupid?

I hope I haven't left anything out.

  • Check the Preferences in Skim? Is the "Check for file changes" option checked? It should be unchecked, I think. And you can change the text editor for Skim to sync with in the Preferences, too. Does that help if you change it to Sublime? – Adam Liter Apr 8 '14 at 15:59
  • And welcome to TeX.SX! – Adam Liter Apr 8 '14 at 16:00
  • Thanks for the prompt response and the welcome :D Why should check for file changes be unchecked? I have tried unchecking it and the sync options are set to Sublime. Still not working though. Skim opens but not at that point and reverse search doesn't work at all. – bteres Apr 8 '14 at 16:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.