2

Consider:

\documentclass[12pt]{article}
\usepackage{tkz-euclide,tkz-fct}
\usetkzobj{all}

\begin{document}

\begin{tikzpicture}
\tkzInit[xmin=-3,xmax=3,xstep=1,ymin=0,ymax=.4,ystep=0.2]
\tkzDrawX[right=3pt,label={$Z$}]
\tkzLabelX[step=1]
\tkzFct[thick,color=blue,domain=-3:3]{1/sqrt(2*pi)*exp(-0.5*\x**2)}
\tkzDrawArea[color=red!50,domain=-1.439531:1.439531]
\tkzText[color=black](0,0.15){85\%}
\tkzDefPoints{1.439531/-0.2/A,1.439531/0/B, -1.439531/-0.2/C,-1.439531/0/D}
\tkzDrawVectors[red](A,B C,D)
\tkzText[below=3pt,color=red](A){$z^{*}$}
\tkzText[below=3pt,color=red](C){$-z^{*}$}
\end{tikzpicture}
 
\end{document}

For some reason, this produces the following image where the area slants up on the left.

enter image description here

Can anyone see a problem with my code or is this a bug?

D.

5
  • For solvers: enable shell escape. – Malipivo Apr 9 '14 at 4:44
  • I've tried an example from section 8.10 on page 41 of the tkz-fct package and it doesn't fit too. My first guess is that we are using different version (of gnuplot?). – Malipivo Apr 9 '14 at 5:26
  • It could be a problem of updating TikZ from v2.1 to version 3 (?). There is a note in the manual on page 8 that it has been tested with TikZ v2.1. – Malipivo Apr 9 '14 at 5:28
  • This is indeed a problem caused by changes between version 2.1 and 3 of PGF. Duplicate of tex.stackexchange.com/questions/165022/… (See also tex.stackexchange.com/questions/165090/…) – Torbjørn T. Apr 9 '14 at 5:46
  • I can confirm that too now as I tried the examples with TikZ v2.1, the output is just fine there. – Malipivo Apr 9 '14 at 5:58

Browse other questions tagged or ask your own question.