7

I'm using IEEEtran class for my conference publication in latex. The guideline says that the captions for figures should be in font size 8. I tried all these methods mentioned in this forum but none worked. Can someone guide me on this please. I found out that the problem is with the figures. The default IEEEtran is somehow being overwritten. http://rauhut.ins.uni-bonn.de/bare_conf.tex

\begin{figure}[tb]
\subfloat[figure A] {
\includegraphics[width=0.24\textwidth]{A}
}
\subfloat[figure B] {
\includegraphics[width=0.25\textwidth]{B}
}
\caption{ this is the caption}
\label{fig:room}
\end{figure}

The preamble is

\usepackage[caption=false]{caption}
\usepackage[font=footnotesize]{subfig}
  • 3
    Can you please supply us with a minimal working example (MWE)? – Werner Apr 9 '14 at 18:46
  • ...since the default seems to be sufficient in terms of the font size already. – Werner Apr 9 '14 at 18:52
  • Your MWE doesn't use the IEEEtran document class. Is this intentional? – Mico Apr 9 '14 at 19:19
  • @Mico, forgot to add that. I have included the IEEEtran class and am getting this error. – kris Apr 9 '14 at 19:22
  • Thanks for updating your MWE. I get no errors when I write \input A instead of \include{A}. Do you absolutely need to use the \include instruction, or can you make do with \input? – Mico Apr 9 '14 at 19:30
3

With default settings, the class IEEEtran already uses font size 8pt for captions:

\listfiles
\documentclass[conference]{IEEEtran}
\begin{document}
  % \maketitle
  \begin{figure}
    \makeatletter
    \caption{Figure caption with fontsize \expandafter\@car\f@size\@nil}
  \end{figure}
\end{document}

Result

\maketitle or putting the figure into an included file does not change the font size.

 *File List*
IEEEtran.cls    2012/12/27 V1.8 by Michael Shell
  ot1ptm.fd    2001/06/04 font definitions for OT1/ptm.
 ***********
  • Hi, I get font size of 1 when running this in my tex file even though it is the standard font size of 10. strange !! – kris Apr 9 '14 at 18:54
  • 3
    A minimal working example (MWE), please. Either you can extend the working example until the problem appears. Or strip the original TeX file down until the problem disappears, then the error is in the code of the latest removal. – Heiko Oberdiek Apr 9 '14 at 18:59
  • I have main.tex that includes A.tex, B.tex. I guess the problem is that I do not mention \begin{document} and \end{document}. How do I then get this? – kris Apr 9 '14 at 19:07
  • @suzanne: The organization of the TeX source does not matter at all. You can have one file or thousands of files (e.g. one file for each word). As starting point for a MWE you can add the figure environment above at that start of the document body, followed by \clearpage. If the point size is wrong, replace \clearpage by \end{document} and forget the remaining part. The you can remove packages and other preamble stuff that do not change the font size of the caption. – Heiko Oberdiek Apr 9 '14 at 19:17
  • HI, I have edited the question with a MWE. – kris Apr 9 '14 at 19:18
1

The problem I had was with the subfig package. I removed it and then the figure caption font-size returned to its original size (should be 8pt).

The following are the list of packages that I've noticed so far that causes this unwanted behaviour with the figure caption fonts by default (unless you are able to change them with suitable options):

  • subfig
  • subcaption
  • caption

use the following options for subfig to fix it.

\usepackage[caption=false,font=footnotesize]{subfig}
\usepackage{fixltx2e}
  • I a not really sure this answers the question. You shouldn't use subfig together with subcaption, subcaption is better. On the other hand, subcaption does not work with all documentclasses, since some classes don't want the user to change anything with respect to the layout. – Johannes_B Jun 16 '16 at 5:46
  • @Johannes_B: The OP stated that the default 8pt font is being overwritten. Setting any of the above mentioned packages does this operation. – Ébe Isaac Jun 16 '16 at 5:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.