6

I am using the the memoir class to typeset a book, where the text has many footnotes. To avoid widows and orphans I use the option \sloppybottom. That has the result of under full pages. memoir normally sets the empty space of these under full lines at the very bottom of the page. But I would like this space to be between the text block and the footnotes. I did not found any solution for that in the documentation for the memoir class.

So I found the package fnpos. This packages seems to do exactly what I need, but I was wandering if there is a memoir way to do this. Or if it is recommended to use memoir with this package.

This is a minimal working example:

\documentclass[a4paper,10pt,twoside]{memoir}

\usepackage{blindtext}
% This package sets the footnotes to the bottom, but isn't there a 
% method to do this with memoir?
\usepackage{fnpos}

\setstocksize{23.5cm}{15.5cm} 
\settrimmedsize{23.5cm}{15.5cm}{*}
\setulmargins{2.25cm}{*}{*}
\setlrmarginsandblock{2.25cm}{*}{*}
\setulmarginsandblock{2.25cm}{2.25cm}{*}

\setheadfoot{\onelineskip}{2\onelineskip}

\setheaderspaces{*}{1.2\onelineskip}{*}
\checkandfixthelayout

\clubpenalty=5000
\widowpenalty=5000
\displaywidowpenalty=5000

\sloppybottom

\renewcommand{\footnoterule}{}
\renewcommand{\footnotesize}{\small}
\footmarkstyle{\textsuperscript{#1}\hfill}
\setlength{\footmarkwidth}{1.5em}
\setlength{\footmarksep}{0em}
\setlength{\skip\footins}{1.6\onelineskip}

\begin{document}
\midsloppy
\frontmatter 
\mainmatter
\chapter[]{This is the title of the Test}

\blindtext
Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Etiam lobortis facilisis
sem. Nullam nec mi et neque pharetra sollicitudin. Praesent imperdiet mi nec
ante. Donec ullamcorper, felis non sodales commodo, lectus velit ultrices augue,
a dignissim nibh lectus placerat pede. Vivamus nunc nunc, molestie ut, ultricies
vel, semper in, velit. U
Lorem lis non sodales commodo, lectus velit ultrices augue,
a dignissim nibh lectus placerat pede. Vivamus nunc nunc, molestie ut, ultricies
vel, semper in, velit. U\footnote{\blindtext}


\section{A section nothing else}
Lorem ipsum dolor sit amet,\footnote{\blindtext} consectetuer adipiscing elit. Etiam lobortis facilisis
sem. Nullam nec mi et neque pharetra sollicitudin. Praesent imperdiet mi nec
ante. Donec ullamcorper, felis non sodales commodo, lectus velit ultrices augue,
a dignissim nibh lectus placerat pede. Vivamus nunc nunc, molestie ut, ultricies
vel, semper in, velit. U \blindtext


\end{document}

As mentioned in the comments, there is the option \feetbelowfloat in the memoir class. But it does not work. Does anybody know why? It seems that this was a bug that was reported 2010. I prefer the package \usepackage{fnpos} because with \usepackage[bottom]{footmisc} I can't use the memoir way to set other footnote options.

10
  • The easiest way is to use \usepackage[bottom]{footmisc} (which is to be preferred over fnpos in my opinion), but it is possible to do it 'by hand' if you need to. And in fact, memoir does have a command \feetbelowfloat, which should work as you wish, but does not always do so in my experience. There is a post to that effect on comp.text.tex from a few years ago
    – jon
    Commented Apr 11, 2014 at 2:30
  • Could you please add minimum working example in your post? It would help solvers a lot.
    – Malipivo
    Commented Apr 11, 2014 at 3:42
  • @Malipivo I added a working example.
    – user5950
    Commented Apr 11, 2014 at 12:27
  • @user5950 that is not a working example. We do not have chapter/Test.tex
    – daleif
    Commented Apr 11, 2014 at 13:20
  • @daleif Sorry, I corrected this.
    – user5950
    Commented Apr 11, 2014 at 13:25

1 Answer 1

6

Since memoir v3.7e it is possible to set the footnotes to the bottom of the page, with:

\feetatbottom

Then we use \raggedbottom or similar, L A TEX will by default attach the footnotes just below the text. In many cases it may look better if the footnotes are being build from the bottom of the texst block up. Issuing \feetatbottom does this. Please note that \feetatbottom has no effect whenever \flushbottom is active.

[Memoir manual, p. 12]

1
  • 2
    Memoir manual link is incorrect (points at microtype package) and is dead as of late 2018. Current memoir manual seems to say nothing about \feetatbottom. The memoir README file does mention it added in version 3.7d, however.
    – whatisit
    Commented Dec 28, 2018 at 19:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .