3

Hej,

I have a problem with biblatex when the author name has to many braces. My MWE:

            \documentclass{article}
            \usepackage[english]{babel}
            \usepackage[style=ieee]{biblatex}
            \addbibresource{ref.bib}
            \begin{filecontents}{ref.bib}
            @report{international_energy_agency_world_2013,
                location = {Paris},
                title = {World Energy Outlook},
                number = {Report Number 1026-1141},
                institution = {Organisation for Economic Co-operation and Development},
                author = {{{International} Energy Agency}},
                urldate = {2014-03-27},
                date = {2013-11}

            }

            \end{filecontents}

            \begin{document}
            This is a reference \cite{international_energy_agency_world_2013}.

            \printbibliography

            \end{document}

It seems biblatex has problems with the three braces of the author because it forgets one closing brace when creating the .bbl file. Since all my references are generated automatically with Zotero, and I need all the words of this author in the references, I wonder if there is a workaround for this problem?

  • is it no option that you mask the brackets with \ like author = {{\{International\} Energy Agency}},? – musicman Apr 11 '14 at 11:18
  • This looks like a bug that should be reported to the maintainers. – Andrew Swann Apr 11 '14 at 11:29
  • I agree it looks like a reportable bug in biber. The problem seems to be not with the name but with the construction of initials: biber is constructing {{I\bibinitperiod} where it ought to construct {{I\bibinitperiod}}. But why do you need {{International} Energy Agency}? Wouldn't {{International Energy Agency}} (which works fine) do? – Paul Stanley Apr 11 '14 at 11:59
  • 1
    I have no problem with {{International Energy Agency}}, which is the correct form in any case. – Paul Stanley Apr 11 '14 at 12:58
  • 2
    I'm afraid not: I think it may well be a genuine bug, probably in biber: the .bbl file produced is malformed; you should definitely report it. (Well, strictly speaking it's a flaw in Zotero -- producing a silly form -- combined with a bug in biber ... but for some reason we are accustomed to forgiving the barbarous .bib files that these tools often produce, and biber should cope gracefully with it.) – Paul Stanley Apr 11 '14 at 15:16
5

Zotero offers you options to export as both "BibTeX" and "BibLaTeX". Using the latter, you should not get triple brackets and that should solve this issue for you (and work better with biber anyways). Even with the BibTeX export, I can't replicate your issue in Zotero unless the first word contains more than one capital letter - i.e. "INTERNATIONAL Agency" turns into {{{INTERNATIONAL} Agency}} but "International Agency" renders {{International Agency}} for me in BibTeX export. If that's not the case for you, please report this on the Zotero forums.

  • When using the standard Zotero BibLaTeX export, all the braces I put manually in my titles to keep capitalized letters are changed to "\{". So I changed the Zotero export library a long time ago to keep the manual braces I set in Zotero to have the upper case letters in my references. And this was working until fine. Just now when I need "International Energy Agency" as a author, Zotero creates the 2 brace around "International" and biber fails to interpret it correctly. – Andy Sweden Apr 14 '14 at 9:10
  • 1
    sorry, can't help then from the Zotero side. As Paul Stanley says above, two curly brackets around corporate authors are correct. FWIW, the better way to preserve capitalization would be something along these lines: github.com/zotero/translators/pull/477 – adam.smith Apr 14 '14 at 14:14
  • Thanks a lot for your help. I just found another way to preserve the full names with capital letters not running into the braces bug. If I change the author name to "International~Energy~Agency" it is working fine with the three capitalized words. – Andy Sweden Apr 14 '14 at 14:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.