2

After having updated Biber from 1.5 version to 1.8, while the build time, I'm getting errors on the \begin{document} of my latex code telling that File ended while scanning use of \field.. I've tried to compile the same full code on this site, and this have worked.

Knowing that I'm on Windows 7 SP1 and using MiKTeX 2.9, how do I to fix this please?

I've tried to use Update (Admin) of MiKTeX for updates, but, after doing this I still getting the same errors.

Full Log file.

Minimal Log file related to the below .tex code.

.tex file

\documentclass[12pt,english,french]{report}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{babel} \usepackage{csquotes}% recommended in output (biblatex) 
\usepackage[backend=biber, style=alphabetic]{biblatex} 
\addbibresource{bibli.bib} 
\usepackage{titletoc}

\begin{document}
\nocite{*}
\printbibliography
\addcontentsline{toc}{chapter}{Bibliographie}
\end{document}

small .bib file

@online{msdn2,
    label    = {MSDN2},
    title    = {Comparatif entre C\# et Visual Basic .NET},
    author   = {Microsoft},
    date     = {2014-01-01},
    url      = {http://support.microsoft.com/kb/308470},
    urldate  = {2014-04-12}
}
67
  • 2
    Well, even though the example is not quite minimal (certainly a lot of the packages and redefinitions could be removed), it works on my computer (MikTeX 2.9, newest biblatex, Biber [v 2.8/1.8 respectively]). Please be more specific on what error message you get and also post the (relevant passages of your) .log and .blg files.
    – moewe
    Apr 14, 2014 at 15:42
  • 2
    As it already happpened to me I guess it's with the binary cache that Biber creates, getting corrupted on an update. The solution is to delete the cache directory, that is somewhere in your personal directory; on my WinXP system it is in C:\Documents and Settings\Bernard\Local Settings\Temp\par-4265726e617264. The important thing to find (and delete) is \Temp\par-4265726e617264. You will find many details [on this thread.][1] [1]: tex.stackexchange.com/questions/140814/…
    – Bernard
    Apr 14, 2014 at 16:00
  • 1
    @dgs: I think I understand now. MiKTeX doesn't have a 64 bit version of biber. Here is what I did, as I also have the 64-bit version: I went on CTAN to MiKTeX packages repository and downloaded miktex-biber-bin.tar.lzma (that's a 32-bit version).I uncompressed it, obtaining a texmf directory. Then I moved the contents of this directory (not the directory itself) in my Local TeXMF directory, as is. Next you'll have to refresh the FNDB as usual, and maybe install a perl distribution (I have Strawberry Perl). That's about all.
    – Bernard
    Apr 15, 2014 at 14:11
  • 1
    @dgs: You should use a really minimal file to see if biber runs on your system or not. In your preamble the only necessary lines are the following: \usepackage{babel} \usepackage{csquotes}% recommended in output (biblatex) \usepackage[backend=biber, style=alphabetic]{biblatex} and \addbibresource{otherbibli.bib} \usepackage{titletoc}. Comment out the rest of the preamble, compile and see what happens (hope you have a good editor that lets you comment out selected portions of text with a single click, or make a copy and delete the spurious lines).
    – Bernard
    Apr 16, 2014 at 0:03
  • 2
    @dgs OK! Good! Thank you! Now we know that biber is working OK. So we know it is installed correctly, it matches your biblatex version and that everything is being found OK at compile time. Now we know the problem is somewhere in your code. That is tremendously helpful. (Though I realise that you want your code to work but we are trying to narrow down the problem so ruling stuff out is progress.)
    – cfr
    Apr 16, 2014 at 0:48

2 Answers 2

2

As the problem actually seems linked to the fact that MiKTeX 64-bit doesn't include biber, which is a 32-bit application, you should take a look at the answers to this question. Don't forget to create a Local TeXMF root if you don't already have one.

Added on 09/20/2015:

Since last summer, MiKTeX 64bits repositories have a miktex-bin-biber-x64.tar.lzma file, so the above-mentioned answers are obsolete. Install biber through MiKTeX Package Manager.

19
  • Please post this as a comment and not as an answer. If this solves the OP's problem, you can then post it as an answer. But from what we know now it might well be an entirely different problem.
    – moewe
    Apr 14, 2014 at 15:59
  • @Bernard, I've downloaded and installed the 32-bits version of MiKTeX which is placed at the first place in the link. And downloaded thr 1.7 biber version and pasted the exe file under C:/../miktex/bin/ but this wouldn't work. I've also tried the 1.8 version, but it still the same.
    – dgs
    Apr 15, 2014 at 16:44
  • Did you refresh the FNDB? Did you put it in a local texmf root? And did you declare this local root via MiKTeX Settings( Roots tab)?
    – Bernard
    Apr 15, 2014 at 17:11
  • 1
    what's the mean of FNDB ?
    – dgs
    Apr 15, 2014 at 17:18
  • Yes, I've putted the biber.exe file under `C:\Program Files (x86)\MiKTeX 2.9\miktex\bin`.
    – dgs
    Apr 15, 2014 at 17:20
1

Upgrading Biber have implied that I must encode my report on UTF8.

Thanks to @Bernard, @cfr, @Speravir, @moewe and @gns_ank.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.