1

Today I wanted to install some new packages in the Package Manager. I got an error message saying:
"MiKTeX Problem Report
Message: HTTP Error
Data: HTTP/1.1 301 Moved Permanently"

I checked and found out, that the repository I used is indeed unavailable at the given adress. I then tried to change the repository. After selecting "Packages shall be installed from the Internet" and clicking "next", the same error message appears and the list of available repositories is not loaded. So basically, I cannot change the repository because the repository I used is not online, which is actually the most important reason for changing the repository.
Does anybody know a solution for this? I guess a workaround would be to change the adress of the repository manually, but for this, one would need to know where it is stored. I've added a screenshot-mashup to show the problem. screenshot-mashup

closed as off-topic by Speravir, Heiko Oberdiek, cmhughes, Masroor, Adam Liter Apr 16 '14 at 0:15

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    I'm not putting this as an answer because I haven't tested it but... Searching my Windows Registry for the mirror I use, I found a key HKEY_LOCAL_MACHINE/SOFTWARE/MiKTeX.org/MiKTex/2.9/MPM/RemoteRepository that stores the address of the remote repository. With the usual caveats about being careful editing the registry you could either delete that key or change it to an accessible repository (the actual repository doesn't matter, since as long as it is accessible you can always change it through the GUI). Hope it helps! – darthbith Apr 15 '14 at 12:11
  • Did you try to change the repository from the menu in the package manager itself? – Ulrike Fischer Apr 15 '14 at 12:29
  • 1
    @Janek Mine is ftp://mirrors.rit.edu/CTAN/systems/win32/miktex/tm/packages/ – darthbith Apr 15 '14 at 12:55
  • 1
    Imho miktex gets the list of repositories from the main miktex server. So if a local repository is down this should affect it. Try to use mpm on the command line. Perhaps this works. Btw: You can download packages directly from CTAN and create a local repository. Get the two miktex-zz-files from /tm/packages and the packages you need and put them in some empty folder outside miktex. – Ulrike Fischer Apr 15 '14 at 13:18
  • 4
    This question appears to be off-topic because it is about an issue that appears to be temporary and localized, and hence cannot be retraced by others. – Speravir Apr 15 '14 at 22:18

Browse other questions tagged or ask your own question.