3

I am currently trying to use the dot2texi package, that requires another package, dot2tex. I first tried to install this latter tool (version 2.8.7) from source, but some obscure python bug made it unusable. It is claimed to be solved for most Linux distributions, but I use Texlive, thus I can't get the fix though my OS package manager. (And I just switched recently from using my OSes package manager to a Texlive-controlled installation!)

Texlive recommends to use its own package manager (tlmgr), unfortunatly, the following command:

tlmgr install dot2tex

says:

package dot2tex not present in package repository

What I don't get is that this package seems to be referenced in CTAN (see second link). How can I solve this issue ?

The command tlmgr install dot2texi did work, but the command dot2tex is not installed.

6
  • It is not a part of repository (yet), the package can be found in PyPi archive, but we cannot install it with pip. Use http://code.google.com/p/dot2tex/downloads/detail?name=dot2tex-2.8.7.zip or http://code.google.com/p/dot2tex/downloads/detail?name=dot2tex-2.8.7.tar.gz and try to install it with EasyInstall.
    – Malipivo
    Commented Apr 16, 2014 at 10:01
  • dot2tex is a Python package, dot2texi is a TeX package distributed in official TeX distributions, that's why the installation is working fine.
    – Malipivo
    Commented Apr 16, 2014 at 10:03
  • @Malipivo Yes, that is exactly what I did. But first it complained about some missing pyparsing package. I installed it (easy_install pyparsing), and then ran into the bug I linked to (_noncomma stuff, can't tell more, I don't know much about Python).
    – kebs
    Commented Apr 16, 2014 at 10:11
  • I gave up trying to install it on Windows, I ran GraphViz (dot) directly, one example of use: tex.stackexchange.com/questions/171106/…
    – Malipivo
    Commented Apr 16, 2014 at 10:15
  • 1
    I wrote an email to the maintainer of dot2tex if he could help us and give that project among other PyPi projects.
    – Malipivo
    Commented Apr 16, 2014 at 10:49

1 Answer 1

3

Kjell Magne fixed that on April 16, 2014. I tested sudo pip install dot2tex on Windows (CygWin) and Ubuntu, it is working well. I enclose the original email.


Pavel,

Thanks for pointing this out. I have updated the pypi project with source files: https://pypi.python.org/pypi/dot2tex/2.8.7

I have not worked on dot2tex for a very long time, but recently I started the process of moving the project to Github. Maybe it will be easier for others to contribute then. The new home of dot2tex will be:
https://github.com/kjellmf/dot2tex
http://dot2tex.readthedocs.org/en/latest/

Regards,
Kjell Magne

9
  • Thank you for the effort, but after 1 - cleaning up all previous reference on dot2tex on the machine, 2 - running sudo pip install dot2tex, I get some strange message, although it claims that installation is ok (see pastebin.com/UnHxVijT). But running dot2tex gives the same error: ImportError: cannot import name _noncomma (see bottom of pastebin).Not at all related to Latex, I assume... For the record, this is with Ubuntu 12.04.
    – kebs
    Commented Apr 16, 2014 at 20:43
  • Found this question: stackoverflow.com/questions/15951748 that seems to be related, not checked yet.
    – kebs
    Commented Apr 16, 2014 at 20:51
  • I would try to upgrade pyparsing (maybe pydot too) in Python and after that I would try to install dot2tex again.
    – Malipivo
    Commented Apr 17, 2014 at 3:42
  • Thanks, did (in that order) sudo pip install pydot --upgrade, sudo pip install pyparsing --upgrade, sudo pip install dot2tex --upgrade, dot2tex => same error as in comment above... Thanks for the efforts, anyway.
    – kebs
    Commented Apr 18, 2014 at 7:07
  • Well, try to uninstall all three packages and try to install just dot2tex. I didn't have pyparsing installed and it installed it for me on-the-fly.
    – Malipivo
    Commented Apr 18, 2014 at 7:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .