1

I'm kind of new in LaTeX.

Every natbib's citing option (using plainnat) gives me a number between parenthesis instead of Author-year.

I'm using natbib as package, plainnat as bibliographystyle, and \citep{x} as the citing command. I recompile and it gives me something like this (7). It should give me something like this: (McCain, 1990). When I use the \citet{x} command it gives me only the name McCain.

I'm using ShareLaTeX, a main .tex file that calls other .tex files (chapters), I'm citing in those other files. What I'm I doing wrong?

1
  • 2
    Hard to tell without a proper MWE. Perhaps you load natbib like so \usepackage[numbers]{natbib}? In that case, remove the numbers option; otherwise, please compose a minimal, complete version of your document illustrating the problem and add it as an edit to your question. – Gonzalo Medina Apr 16 '14 at 17:30
1

It works here:

\documentclass{article}
\usepackage{natbib}

\begin{document}

\citep{article-full} \citet{article-minimal} \cite{whole-journal}

\bibliographystyle{plainnat}
  \bibliography{xampl}

\end{document}

Natbib with plainnat

As Gonzalo Medina points out, your question should include an MWE.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.