0

I'm trying to get citations working with LyX but I've found that I'm getting the entire citation listed. So where it should say [1] I am getting Example(John Tosh…) ect. My document preamble is:

\usepackage{nag}
\usepackage[style=british]{csquotes}
\usepackage{fancyhdr} 
\usepackage{microtype}
\usepackage[T1]{fontenc}
\usepackage{pslatex}
\usepackage[style=oscola,
natbib=true]{biblatex}
\bibliography{/Users/jamie/Documents/Law and History}

Is there a way to resolve this?

MWE:

\documentclass[british]{article}
\usepackage{mathpazo}
\usepackage[OT1]{fontenc}
\usepackage[latin9]{inputenc}

\makeatletter
\@ifundefined{date}{}{\date{}}
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%% User specified LaTeX commands.

\usepackage[natbib=true,
style=numeric,
style=oscola]{biblatex}
\bibliography{/Users/jamie/Documents/Law and History}


\usepackage{babel}
\begin{document}
THE QUICK BROWN FOX JUMPED OVER THE LAZY DOG\citet{Tosh:2010aa} dfdasfads
\citep{Tosh:2010aa}



\printbibliography
\end{document}

With that document I am getting: THE QUICK BROWN FOX JUMPED OVER THE LAZY DOG\footciteref Tosh dfdasfads (ibid)' instead ofthe quick brown fox jumped over the lazy dog. [1]

8
  • Please complete your code to create a minimal working example (MWE) that illustrates your problem. It is a lot easier to help when you include all the necessary code to reproduce the issue and eliminate unnecessary packages which are unrelated to the problem. Who knows? You may even solve the problem yourself in the process of creating your MWE!
    – cfr
    Apr 18, 2014 at 0:26
  • I think the problem lies with \usepackage[style=oscola, natbib=true]{biblatex} .I also have the biblatex.module enabled. Thank you for your time
    – Jim
    Apr 18, 2014 at 0:29
  • So use a different style or don't use natbib. Really, if you don't provide code so somebody can reproduce the issue but only say you think you already know what the problem is, I'm not sure quite what you think somebody can say.
    – cfr
    Apr 18, 2014 at 0:36
  • I'm sorry that I can't be more helpful, I am quite new to lyx and latex. I think I am doing something wrong with the way I have set up that line and I can't work out what. If I remove style=oscola, then I get the proper [1] format. Sadly I have to use OSCOLA, because it is a required standard.
    – Jim
    Apr 18, 2014 at 0:43
  • Did you read the information in the link I provided? Producing an MWE is not difficult - tedious, sometimes, but it does not require any particular skills, LaTeX or otherwise. Moreover, I'm confused. The point of loading the style is to comply with it. If you need to use that style, you need that style. The fact that it gives different output is expected. That is the job of a style - it changes the formatting of references and/or citations. (Both in this case.) So if you are meant to use it, you are meant to use it. I'm not sure what you are asking.
    – cfr
    Apr 18, 2014 at 0:47

1 Answer 1

1

Here is a partial, possible solution. I'm not sure if this will work for you or not because it depends a great deal on what else is going on in your document. This reformats footnote markers so that they conform to the requirements of the citation style.

I've used a sample bib entry from the example file provided by the package and some of the code you originally posted. I've also noted a couple of other things I think you could improve easily in terms of options you are using.

\documentclass[british]{article}
\usepackage{babel}
\usepackage[T1]{fontenc}% much better than OT1
\usepackage{mathpazo}
\usepackage[utf8]{inputenc}% much better to switch to utf8 if you can
\usepackage[style=british]{csquotes}
\usepackage[style=oscola,natbib=true]{biblatex}
\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@legislation{gorchymyn,
    title          = {Gorchymyn Mesur Teithio gan Ddysgwyr (Cymru) (Cychwyn Rhif 2)\nopunct},
    number         = {SI 2009\slash 2819},
    pagination     = {regulation},
    keywords       = {cy},
    userb          = {Cy 245},
    entrysubtype   = {secondary},
    language       = {welsh},
}% entry from oscola documentation
\end{filecontents}

\bibliography{\jobname}
\let\citet\footcite% horrible kludge

\makeatletter
  \def\@makefnmark{\hbox{\normalfont[\@thefnmark]}}% this redefines the way footnote markers are formatted. It will affect *all* footnotes - not just citations.
\makeatother

\begin{document}

THE QUICK BROWN FOX JUMPED OVER THE LAZY DOG\citet{gorchymyn} dfdasfads

\printbibliography

\end{document}

A citation and reference

\citet does not seem to work without a kludge (above) but \citep does.

2
  • Thank you so much. I changed the kludge to citep and it works perfectly in Lyx. I think the problem stems from Lyx's problems with Biblatex and some issues with Natbib. Without your help, I would never of got it to work.
    – Jim
    Apr 18, 2014 at 12:27
  • @Jim No problem. Glad it helped. I think the main problem actually had nothing to do with citations as such but just to do with the formatting of footnotes. But figuring this out was complicated by the problems with \citet - I'm not sure if this is an incompatibility (natbib + oscola) or a more general issue but it certainly caused some weird and not-very-transparent errors! Note that you are not actually using natbib this way. Rather, biblatex just maps standard natbib commands to rough biblatex equivalents. (But not, it seems, \citet...)
    – cfr
    Apr 18, 2014 at 13:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .